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Overview
About this guide
This document is for people who currently use or have used Microsoft Office and would like
to investigate or are actively changing to OpenOffice.org. It is aimed at intermediate to
advanced users of Microsoft Office so if the functionality in OpenOffice.org is not
significantly different then, typically, that function is not mentioned.
This document currently has 13 chapter headings:
1 Why OpenOffice.org: a very brief outline of the pros and cons of OpenOffice.org versus
Microsoft Office.
2 General Interface differences: gives an overview of the differences in the interface between
OpenOffice.org and Microsoft Office that are consistent across the applications. This chapter
is designed for being the background material for an introductory course on migrating to
OpenOffice.org from Microsoft Office.
3 Customizing the Interface: explains how to change the interface so that users can make
OpenOffice.org work as close as possible to how they have worked in the past. It doesn't say
make these changes to make OpenOffice.org work like Microsoft Office, as both applications
are highly configurable it seemed, to the author, to make more sense to say how to change
things rather than give a proscribed list.
4 Conversion of Microsoft Office Files: briefly discusses philosophical differences in file
formats between the office suites, how to do bulk conversions of files, general issues when
collaborating with people still using Microsoft Office, and a mention that macros need to be
manually converted.
5 Text Documents: this is a more detailed exploration of how to use the OpenOffice.org
word-processing application, Writer. This chapter expands on the interface differences
covered in chapter 2 that are specific to Writer, discusses techniques for avoiding problems
when working with people still using Microsoft Word, and goes into detail about how to use
those features which are significantly different: Mail Merge, Envelopes, Page styles and page
numbering, Index/Tables, Conditional text, and Master documents.
6 Spreadsheet documents: this is a more detailed exploration of how to use the
OpenOffice.org spreadsheet application, Calc. This chapter expands on the interface
differences covered in chapter 2 that are specific to Calc, discusses techniques for avoiding
problems when working with people still using Microsoft Excel, and goes into detail about
how to use those features which are significantly different: Conditional formatting and styles,
Working across spreadsheets, web pages and database data, and Printing.
7 Presentation documents: as the OpenOffice.org presentation application, Impress, is not
significantly different is use from Microsoft PowerPoint this chapter is comparatively brief,
but it does outline some differences. It may also be worth seeing in the appendices
PowerPoint custom animations – Impress object effects and PowerPoint – Impress slide
transitions.

Migrating from Microsoft Office to OpenOffice.org 1.1.1

viii

8 OpenOffice.org as a replacement for FrontPage: this chapter is yet to be written.
9 Draw: this chapter is yet to be written.
10 FontWorks (WordArt equivalent): describes how to use OpenOffice.org's FontWorks
which serves a similar purpose to Microsoft WordArt.
11 Math formula editor / Equation Editor: describes how to use OpenOffice.org Math for
entering equations. It recommends using commands rather than the GUI (Graphical User
Interface) and the commands are outlined in the appendix Math formula – symbols and
commands.
12 Data-sources: Microsoft has a separate application, Access, for working with databases,
OpenOffice.org integrates working with databases throughout the application. This chapter
introduces: Working with a data-source (dBase example), Creating a data-source from a
spreadsheet, Database Forms, and Reports.
13 Converting VBA macros to OpenOffice.org macros: this chapter is yet to be written.
This document does not aim to be complete but will hopefully give a better insight than
typical magazine reviews. It is not a complete reference text. Two reference texts are: Que's
“Special Edition Using Star Office 6.0” by Michael Koch, and Prentice Hall's “StarOffice 6.0
Office Suite Companion” by Solveig Haugland and Floyd Jones. Both of these texts were
used as reference material in the writing of this document, but this document is targeted at
Microsoft Office users rather than a generic reference text, it also covers material that neither
of these books do.
Portions of this document come from the book “Taming OpenOffice.org Writer 1.1” by Jean
Hollis Weber, available at: http://www.taming-openoffice-org.com/index.htm.
A commercially available book which appears to cover similar material to this document (the
author has not seen this book - only the advertisement). See
http://www.hentzenwerke.com/catalogpricelists/ooo501tofc.htm.
This document assumes the reader has access to a computer running OpenOffice.org, so does
not have screen cuts (with one exception).

Conventions used in this guide
This guide uses the following conventions:
•

Bold indicates menu options, buttons, and other items that you select on the screen

•

Italics indicate the name of a toolbar or window

•

Step-by-step directions are numbered to make them easy for you to follow. When you
have a choice, the choices are presented in a bulleted list, just like the bulleted list you're
reading now

•

“Right click” refers to clicking the alternate mouse button (usually the right button)

•

“Click” refers to clicking the main mouse button (usually the left)
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Terminology
OpenOffice.org: This document is based on OpenOffice.org 1.1.1. Unless it is stated
otherwise, assume that everything mentioned for OpenOffice.org is true for StarOffice 6.0.
The main difference between the two is that StarOffice is available for a small fee which
entitles the user to support from Sun. StarOffice also includes some proprietary software
such as a limited version of Adabas.
Microsoft Office: This document is based on Microsoft Office XP unless otherwise stated.
The names of the applications for the two suites are different as outlined in Table 1 below.
Table 1: Office application names

Application

Microsoft OpenOffice.org
Office

Word processor

Word

Writer

Spreadsheet

Excel

Calc

Presentation Package

PowerPoint

Impress

Groupware client

Outlook

None
(See http://groupware.openoffice.org/ for progress)1

Database management system

Access

There is no separate application. But built into
OpenOffice.org is all the power of a full graphical user
interface for a database client.

Copyright and trademark information
The contents of this Documentation are subject to the Public Documentation License, Version
1.0 (the "License"). You may only use this Documentation if you comply with the terms of
this License. A copy of the License is available at:
http://www.openoffice.org/licenses/PDL.rtf
The Original Documentation is Migrating from Microsoft Office to OpenOffice.org 1.1.1. The
Initial Writer of the Original Documentation is Ian Laurenson © 2004. All Rights Reserved.
(Initial Writer contact: hillview@paradise.net.nz)
Contributor(s): ______________________________________.
Portions created by ______ are Copyright (C)_________[insert year(s)]. All Rights Reserved.
(Contributor contact(s):________________[insert hyperlink/alias]).
All trademarks within this guide belong to legitimate owners.

1 While not directly related to this document for those looking for an open source group-ware server see:
http://www.opengroupware.org/.
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Feedback
Please direct any comments or suggestions about this document to the author at
hillview@paradise.net.nz or alternatively to dev@documentation.openoffice.org. The author
really would like some feedback! Especially if you think this document is worth improving
or you would like to see the unfinished chapters written. No feedback and the author may just
scrap this project.
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Why OpenOffice.org

1 Why OpenOffice.org
1.1 Some OpenOffice.org advantages
•

You can legally use and share software at low / no purchase cost

•

The standard file format for OpenOffice.org is XML. XML is an openly documented
file format that is being widely adopted, so your documents created in OpenOffice.org
now will continue to be readable in the future

•

OpenOffice.org, like all open source software, enjoys ongoing support and
maintenance that is not at the whim of a company, or dependent on a company's
survival

•

OpenOffice.org is able to be run on the widest range of operating systems. Including
Microsoft Windows, Mac OS X, Unix based systems (such as Linux), and Solaris

1.2 Some OpenOffice.org disadvantages
•

Groupware is not yet implemented

•

No database management system has been built in (but a lot of functionality is)

•

Cost of converting existing Microsoft Office files, particularly if they contain macros
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2 General Interface differences
While the interfaces of OpenOffice.org and Microsoft Office are generally similar, there are
some differences. The purpose of this section is to outline these differences and how to work
with them. One of the underlying differences is the degree of integration of the applications.
For instance, it is possible to open a Calc spreadsheet in Calc while in Writer.
Below is a screen cut of the Writer interface.
Data source
viewer

Title bar

Data source
viewer
explorer
window

Menu bar
Function bar
Navigator

Gallery
Object bar
more bars

Stylist

Object bar
Insert object
toolbar

Workspace
window

Insert
toolbar

Main toolbar

Draw toolbar

Main toolbar
more buttons

Status bar

Figure 2.1Writer user interface

2.1 Help
Help is very similar in OpenOffice.org to its equivalent in Microsoft Office.
Pausing the mouse pointer over a button causes it to display a description of the button.
Shift + F1 changes the pointer to a question mark. When the question mark pointer is over a
button or control on a dialog a more detailed description is displayed.
Pressing F1 displays contextual help (based on what is currently selected).
There is an equivalent to the Microsoft Office “Office Assistant”. This is
called the Help Agent. It is not as cutesy as Microsoft Office's “Clip it” et al,
but it “lightsup” alerting the user that help is available for an event that has
just happened. Examples are when a user first saves a file, or when a word
gets automatically corrected. The Help Agent can be turned off and on from
the Help menu.
More help is available in the OpenOffice.org forums accessible via:
http://www.OpenOffice.orgforum.org.
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Another thing to do, is to see if someone has logged a fault or request for a new feature. This
can be done at http://www.openoffice.org/. Before the user can log faults / feature requests,
they are required to register. Registration has no cost associated with it; nor will the
registered user receive spam.

2.2 Zoom – the view percentage
To change the size at which the document is displayed on the monitor, use: View > Zoom or
right click the number with a percentage sign next to it on the status bar.
In Writer, the Optimal option zooms the display so that the document is displayed between
left and right margins. The zoom factor is automatically adjusted as the side panels are
displayed.

2.3 Auto Correct / Auto Format
Writer adds an auto-complete feature to words, so that when a user is typing Writer tries to
predict what the completion of the word will be. Settings for this feature:
Tools > Auto Correct/Auto Format... > Word completion.

2.4 Menus
One of the differences in menu location is that page layout is considered to be a format so is
found under the format menu (Format, Page...) rather than the file menu.
For customizing menus see 3.2 Customizing Menus on page 16 below.
The font used in OpenOffice.org for menus is different to that used in Microsoft Office. To
change the font:
1) Tools -> Options... > OpenOffice.org -> Fonts Tab
2) Tick "Apply replacement Table"
3) Type "Andale Sans UI" to the text box labeled "Font"
4) Select "Microsoft Sans Serif" from the "Replace with" dropdown
5) Click on the green arrow
6) Click OK
This is based on work by “Tommi” available from:
http://www.bloggidity.com/web/2004/03/31/openoffice_tweaks_254.htm).
2.4.1 Personalized Menus
There is no personalized menus option. This feature in Microsoft Office reorganizes the
menus so that the most frequently used options are displayed first. However, the degree of
context sensitivity, based on current cursor location, is much greater in OpenOffice.org than
Migrating from Microsoft Office to OpenOffice.org 1.1.1
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in Microsoft Office. For instance, in Writer, the menu items for working with tables, found in
the Format menu, are only displayed when the cursor is in a table.
In OpenOffice.org there are some menu items that are relevant to the current cursor location,
but which are inactive for some reason. For example the sort option (Tools > Sort) is not
available when nothing is selected. By default these menu items are not displayed. To make
them visible use: Tools > Options > OpenOffice.org > View > Inactive Menu Items.

2.5 Mouse use
2.5.1 Long click
OpenOffice.org introduces the concept of a long click for some toolbar buttons. A normal
quick click and that toolbar button acts as depicted. A long click (click and hold mouse
button down without moving the mouse) displays a sub-menu or tear off toolbar. See 2.6.2
Tear-off toolbars on page 5 below
2.5.2 Drag and drop
While drag and drop does work, there is less feedback with pointer changing in
OpenOffice.org than in Microsoft Office. E.g. Moving the pointer onto a selected piece of
text the pointer remains the usual I bar rather than changing to an arrow.
2.5.3 Right click
Right clicking in OpenOffice.org does display a context menu BUT it doesn't select what has
just been right clicked on, the context menu is for what is currently selected.

2.6 Toolbars
The top toolbar (default position) is called the Function Bar. The Function Bar is consistent
across the OpenOffice.org applications.
The second toolbar across the top (default location) is the Object Bar. The Object Bar is a
context-sensitive bar which shows the relevant toolbars in response to the cursors current
selection. For example when the cursor is in a table, the object bar provides both a Table Bar
and a Text Bar. To toggle between these bars click the large triangle button at the right end of
the Object Bar.
The toolbar down the left side (default position) is the Main Toolbar. The Main Toolbar has
the buttons most relevant to the current application.
Buttons with a small green triangle will display one of the following with a long click
depending on the button:
•

Sub-menus (e.g. the New, Paste, Undo, Redo, Autotext buttons)

•

Tear-off toolbars (e.g. Font Color, Highlighting, Insert buttons)

•

A quick way of selecting things like number of cells or columns (e.g. Insert table, Insert
frame, Insert Section).
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For customizing toolbars see 3.1 Toolbars on page 16 below.
2.6.1 Moving toolbars
To convert a docked toolbar to a floating toolbar and vice versa: Control + double click a
blank area of the toolbar. To dock a toolbar at a different edge: Control + drag floating
toolbar to the desired edge.
2.6.2 Tear-off toolbars
As mentioned above these tear-off toolbars are accessed by giving a long click on the button
with a small green triangle. These toolbars are always floating (i.e. they cannot be docked at
an edge), but they can float over the top of other toolbars and docked / floating windows. To
shift the tear-off toolbar drag the toolbar by its titlebar.
2.6.3 The Draw toolbar
In Writer and Calc the draw toolbar is a tear-off toolbar from the Main Toolbar (down the
left by default), whereas in Microsoft Office the Draw toolbar is, by default, across the
bottom of the application window. In Draw and Impress, the tools found on Microsoft Office
's Draw toolbar are to be found directly on the Main toolbar.
2.6.4 The Load URL drop-down on the Function bar
The drop-down on the left of the Function bar is called Load URL” it lists, up to, the last 100
files that have been open in OpenOffice.org. Select a file from the list to open it.

2.7 Side panes - Docked / Floating Windows
Microsoft Office XP introduced to Microsoft Office the concept of side panes. These are the
closest equivalent to OpenOffice.org's Docked / Floating Windows. In OpenOffice.org these
include:
•

Navigator (to help move around in the document – the closest equivalent in Microsoft
Office would be the Outline view in Word)

•

Stylist for applying styles

•

Gallery (a clip art viewer)

•

Function List (available only in Calc)

•

Data Source View sometimes called the beamer (available in Calc and Writer and can
only be docked at the top)

There is no equivalent of the Microsoft Office Clipboard for handling multiple copies.
2.7.1 Docking and Undocking
This is the same as for the toolbars, Control + Double click docks / undocks. Control +
drag the title bar will shift the edge at which it docks.
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It is possible to have two windows in the same area. E.g. Having the Stylist and the
Navigator at the right edge with one above the other rather than side by side. Then the show /
hide and stick / floating buttons work for both “docked windows”.
2.7.2 Resizing
The docked windows can be resized by moving to the border between its window and the
next window. When the mouse pointer changes to a double ended arrow, click and drag to
the desired size.
2.7.3 Show / Hide
Even though these windows are quite easy to display or hide entirely either through key
presses or from toolbar buttons, they have their own button that works like a minimize to the
edge button. It is a triangle pointing to the current docked edge to hide it, or pointing out
from the edge to show it.
2.7.4 Stick / Floating pin
With the window “floating” but docked at an edge, it overlaps the workspace window. Click
the pin to “stick” it so that the workspace window is resized so that so that the entire width of
the workspace window is visible.
2.7.5 Navigator
Activated / deactivated by F5, or the Navigator On/Off button in the Function Bar or Edit >
Navigator. This shows the different objects in the current document. For example in Writer
it shows the list of headings and has controls similar to Outline view in Word. The dropdown at the bottom of the Navigator is for selecting whichever of the currently open
documents has information displayed in the navigator. (For more info see Navigator in each
of the applications.)
2.7.6 Stylist
This can be activated / deactivated by F11, or the Stylist On/Off button in the Function Bar
or Format > Stylist.
To change the type of styles displayed, use the buttons across the top. E.g. In Writer the
buttons are: Paragraph Styles, Character Styles, Frame Styles, Page Styles and Numbering
Styles. The drop-down at the bottom of the stylist determines which of these different types
get displayed. For example in Writer for character styles the options are: Hierarchical, All,
Applied and Custom. The style of the current selection is highlighted. See Help > Index >
type “Stylist” > creating new Styles from selections and updating from selections; and
Help > Find > type “Applying Styles” > Applying Styles in Fill Format Mode for how the
other buttons work.
2.7.7 Gallery
This is activated / deactivated by the Gallery button in the Function bar or Tools > Gallery.
Note: There is no default key press.
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This is OpenOffice.org's equivalent to Microsoft Office's Media Gallery, except it doesn't
have ties to the Web. Use drag and drop or right click > Insert to place the clip art into the
current document.
Note: In Writer there are options to insert the graphic in the background.
To add clipart: Click New Theme and follow the dialog. To add clip art to an existing theme
the icon needs to be green rather than red2 and right click > Properties.... It is also possible
to drag and drop a picture from the document into the gallery.
2.7.8 Data source viewer
Activated / deactivated by F4 and by the Data sources button in the Main toolbar.
The Data source viewer window behaves differently in that it can only be docked at the top.
It is possible to drag and drop fields from data sources to create fields in the current
document. See 5.5 Mail Merge on page 41 below for an example.
For working with the Data source viewer see 12 Data-sources on page 70 below.

2.8 Page preview
File > Page Preview in OpenOffice.org is the equivalent of Microsoft Office's Print preview.
The Zoom button in OpenOffice.org simply zooms the view, it doesn't provide a pointer with
which the user can select an area to zoom in on.

2.9 Keyboard shortcuts
The standard keyboard shortcuts for clipboard operations (Control + X, C, V), undo
(Control + Z) ,redo (Control + Y), save (Control + S), open (Control + O) and new
(Control + N) are the same.

2.10 Smart Tags
These are not available in OpenOffice.org. In Microsoft Office XP they are like context
menus for things like pasting text so that the user could alter the way the paste worked.

2.11 Special characters / symbols
The equivalent of insert symbols is:
Insert > SpecialCharacters
Note: The dialog displayed doesn't have a second tab for common special characters such as
em-dash. Workarounds are to use autoformat/autocorrect, autotext or to record a macro.
2 A red icon indicates that the folder that stores the theme is read-only for the current user.
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2.12 File Management
2.12.1 Default locations
Use Tools > Options > OpenOffice.org > Paths to set the default locations for where files
are stored. The two path settings of interest (at this stage) are My Documents and Templates.
My Documents only allows one location. I.e., it is not possible to have a separate folder for
each of the applications. This folder is the default location for File > Save As , and is the
folder that gets displayed when the Default Directory button,
, is clicked in the Open and
Save As dialogs.
For templates it is possible to have more than one folder specified. These are the folders that
are shown down the left side of the dialog that gets displayed for: File > New > Templates
and Documents (see 2.12.2 Creating New files below).
2.12.2 Creating New files
As with Microsoft Office in OpenOffice.org, there are a number of different ways of creating
new files. What is different is that you can initiate the creation of any OpenOffice.org file
type from any application. For instance it is possible to start creating a spreadsheet while
working in Writer.
Different ways of creating a new document:
•

File > New

•

Use the New button on the Function bar. This button has the long click feature for
selecting the type of document to be created

•

From a “Quick start” program. For instance, the Microsoft Window's version of
OpenOffice.org has a quick start icon in the system tray

•

Control + N

•

Using AutoPilots (OpenOffice.org equivalent to Microsoft Office Wizards):
File > AutoPilot

2.12.3 Default Templates
To change the default template:
7) Save the template using File > Templates > Save... Category Default, the name of the
template is not important
8) File > Templates > Organize...
9) Double click Default folder
10) Select the template by clicking on it
11) Either right click or Commands > Set as Default Template
To reset back to the default (in-built) template:
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File > Templates > Organize... > Commands > Reset Default Template > [xxx
Document] where xxx is the type of document to be reset.
2.12.4 Template folder management
To make it easier to manage your templates such as creating and deleting folders
(categories), and importing Templates into the folders use:
•

File > Templates > Organize... > Double click the desired folder > Commands

2.12.5 The Open and Save As dialogs
Running under Microsoft Windows there is the option of using either the OpenOffice.org
dialogs or the ones provided by Microsoft Windows: Tools > Options... > OpenOffice.org >
General > Use OpenOffice.org dialogs.
Note: The dialogs provided by Windows are not the dialogs used by Microsoft Office!
What follows is for the OpenOffice.org open and save as dialogs.
Right click on file displays a context menu for deleting and renaming a file. It is not possible
to copy and paste files within the dialogs for moving files around.
The three buttons in the top right are, from left to right:
•

Go up one level in the folder (directory) heirarchy. Note that this is a long click button if
you want to go up higher than just one level.

•

New folder

•

Default Directory (see 2.12.1 Default locations on page 8 above).

For OpenOffice.org documents that have been saved with more than one version use the
version drop-down to select which version you wish to open in read only mode.
Note: For Microsoft Office documents only the current version can be opened.
File types has the same concept in OpenOffice.org as in Microsoft Office. For more
information on these file formats see 4 Conversion of Microsoft Office Files on page 19
below.
The read only check box opens the file for reading and printing only. Consequently most of
the toolbars disappear and most menu options are disabled. An Edit File button is displayed
on the Function toolbar to open the file for editing.
It is possible to open files from the web using URLs. In theory it is possible to save files but
the author hasn't been able to get this to work. Having a local copy and using an FTP
program to copy it to the server feels safer to the author anyway.
2.12.6 Password protection
To protect an entire document from being viewable without a password there is an option on
the SaveAs dialog to enter a password. This option is only available for files saved in Xml
format (I.e., OpenOffice.org format) and the files are encrypted (unlike early versions of
Microsoft Office).
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2.12.7 Privacy Options
To include or remove personal information (e.g. Author) with the document, File >
Properties... > General. The Delete button removes information such as editing time etc.
The Apply User data check box includes / removes information such as “Author”.
2.12.8 PDF file (Adobe reader) file creation
All of the applications have the ability to export documents as PDF files. Click the Export
Directly as PDF button on the Main toolbar, or use: File > Export as PDF...
2.12.9 Creating web pages (HTML files) overview
This section is based upon an article by Ralph Krause, titled “HowTo: Creating web pages
with OpenOffice.org”. The original document is available at:
http://www.linuxjournal.com/article.php?sid=6289.
All of the OpenOffice.org applications can be used to create web pages, and this section
introduces their HTML capabilities.
Writer
Writer's HTML capabilities include saving existing documents in HTML format, creating
new documents as HTML and creating several different types of web pages using a wizard
(or AutoPilot in OpenOffice.org speak).
The easiest way to create HTML documents is to start with an existing Writer document.
You can view it as it will appear on a web page by: View > Online Layout.
Links can be inserted and modified using the hyperlink dialog. Display the dialog by clicking
Hyperlink Dialog on the Function toolbar or Insert > Hyperlink. Writing or pasting a URL
will (depending on AutoCorrect/AutoFormat settings) automatically convert to Hyperlinks.
To edit an existing link either move the cursor into the link using the keyboard or toggle the
“HYP” to “SEL” in the status bar and use the mouse, Edit > Hyperlink. From the Hyperlink
dialog, you can choose the type of link, as well as specify the link's address, text and how it
should be displayed (e.g., in a new window). To turn existing text into a link, simply
highlight it before opening the Hyperlink dialog. You have to click Apply to insert the link
into your document before closing the window.
Note: Cross references do not become hyperlinks in an HTML document.
To save in HTML format select Save As from the File menu and specify HTML document as
the file type.
Note: One thing that Writer doesn't do is replace multiple spaces in the original document
with the HTML code for non-breaking spaces.
For a large document, Writer can save it as a series of HTML files with a table of contents
page. To do this:
1) Decide which headings in the document should be on separate pages and make sure
that they have the same formatting style (e.g., Heading 2)
2) File > Send and click on Create HTML Document
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3) In the dialog box that appear s enter the file name to save the pages under. Also
specify which style indicates a new page (as decided on in step 1)
4) Click Save to create the multipage HTML document. According to the DOCTYPE tag
inserted by OpenOffice.org, the resulting HTML files conform to the HTML 3.2
standard.
OpenOffice.org's wizard, called AutoPilot, allow the user to create several types of standard
web pages. To use the AutoPilot:
1) File > AutoPilot > Web Page... .
2) In the dialog select a template and layout to use. Templates define the structure of the
web page, while layouts determine font styles, colors and page background. Some
templates included with OpenOffice.org are:
•

A list with table of contents

•

Contact Form

•

Photo Album

•

Single column with subheading

•

The standard template provides a document with a page heading in large text,
example links, space for body text and a line indicating when the document was
last changed.

Changes in the template and layout selections are reflected in the document immediately so
that the user can preview them.
To create a template based on your selections placing a check in the Create template box.
This template is available in the future by: File > New > Templates and Documents.
Clicking the Create button closes the dialog and allows the user to edit the document. If the
user elected to create a template, the Templates dialog will appear so that the template can be
named.
To edit or view the document's underlying HTML code: View > HTML-Source or click
HTML Source on the Main toolbar.
Calc
Calc can save its files as HTML documents. If the file contains more than one sheet, the
additional sheets will follow one another in the HTML file. Links to each sheet will be
placed at the top of the document. Calc also allows the insertion of links directly into the
spreadsheet via the Hyperlink dialog.
Draw
It is possible to export drawings as a Macro Media Flash file: File >Export and choose
macro Media Flash for the file type.
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The drawing program allows you to turn your drawings into a series of web pages. These
web pages are created by using:
1) File > Export > Select Web Page as the file type, supply a name for the resulting
HTML file and click Save
2) In the HTML Export window select whether to use an existing design for the web
pages or create a new one
3) Click Next to select the type of web pages to create. The types available are Standard
HTML format, Standard HTML with frames, Automatic and WebCast. There is also an
option for creating a title page for the presentation
•

Standard HTML generates a series of pages, each page containing one slide.
Navigation links are available to move from slide to slide

•

Selecting Automatic for the publication type generates a series of pages, each set
with the Refresh meta tag that causes a browser to automatically cycle through
each web page

•

WebCast, generates an ASP or Perl application to display the slides

4) After selecting the type of publication to create, select whether to convert the slides to
GIF or JPG files and what resolution should be used
5) If create a title page was chosen in step 3 above, supply the information for it on the
next page. The title contains an author name, e-mail address and home page, along with
any additional information specified
6) In the next page of the HTML Export wizard choose between text or graphics for the
links used to navigate through the slides. For graphical navigation buttons, there are
several styles to choose from
7) Next select the color scheme to use on the web pages. Available schemes include the
document's existing scheme, one based upon browser colors, and a completely userdefined scheme
8) Click the Create button to generate the HTML files
Note: The HTML and image files are placed in the same directory, so it is advisable to
create unique directories for each drawing.
Impress
Exporting presentations from OpenOffice.org's Impress application is similar to exporting a
drawing from Draw. Use File > Export and select HTML document as the file type. The
only difference is that there is an option to display each slide's notes along with the slide.
2.12.10 Document properties
Some differences in document properties:
•

Summary / Description: OpenOffice.org doesn't include fields for manager or category

•

Statistics: For Writer this is where you find the word count
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•

Custom / User defined: OpenOffice.org provides only four fields. To rename the fields
use: Info fields...

•

The internet tab is for dynamic web pages – such as a page saying “redirecting you to ...”

2.12.11 Searching for files
There is no Find Files command built-in to OpenOffice.org for finding files that contain
specific text. However, a python script that does this is available from:
http://www.danielnaber.de/loook/.
2.12.12 Working with multiple files
The Window menu displays all of the currently open documents in OpenOffice.org not just
the current application's open documents.
Each open document has its own window, so depending on the operating system, use the task
bar or ALT + Tab to switch between the currently open documents. Control + F6 doesn't
work.
There is Object Linking and Embedding (OLE). See 4.4.1 Object Linking and Embedding
(OLE) on page 20 below.
In the Windows version of OpenOffice.org, it is possible to copy and paste special cells from
a Calc spreadsheet into a Writer document as a Dynamic Data Exchange (DDE) link. It is
also possible in the Windows version to create a DDE field. Neither of these options are
available in the Linux version, yet opening a file created in the Windows version on a Linux
version works (some modification of the file location may be necessary). See
http://www.openoffice.org/issues/show_bug.cgi?id=5317.
In neither version is it possible to have a link to a chart.
For information on what happens with imported files containing DDE links see 4.4.2 Linked
files on page 21 below.
2.12.13 Autosaves
To turn on/off autosaving and set the time period:
Tools > Options... > Load/Save > General > AutoSave every
Warning: Autosave works like the old Excel autosave – it saves to the current
file – overwriting it!
2.12.14 Version control
This is where more than one version of a file is saved under the one file name. In Microsoft
Office each version contains the changes that have occurred to the document (like fast saves),
in OpenOffice.org each version is complete. To use: File > Versions...
See 2.12.5 The Open and Save As dialogs on page 9 above for more information.

Migrating from Microsoft Office to OpenOffice.org 1.1.1

13

General Interface differences

2.13 Find and Replace
Find and replace are combined in OpenOffice.org so there isn't a separate menu entry or key
shortcut for replace.
There is no “word forms” search.
Having performed a search and having closed the dialog box, the key shortcut to repeat the
search is: Control + Shift + F.
Searches are paragraph based so there is no way of searching for text either side of a
paragraph marker.
Note: As manual page breaks are handled by changing the paragraph format of the first
paragraph on the new page, and when searching for formats this option is grayed out there
is no way to search for “manual” page breaks. The other possibility is under attributes and
page style but this doesn't work either.
2.13.1 Some tips for search and replace
It is common to do several search and replaces on the same selection, however
OpenOffice.org doesn't “remember” the original selection. So before doing the find and
replace, bookmark the selection in Writer or define a range name for the selection in Calc, so
that by using the Navigator, the same range can be quickly reselected.
Doing a “find all” selects all the pieces of text that match the criteria, so it is possible to
perform any operation on all of these selected pieces of text that is possible on a single
selection.
2.13.2 Attributes
The Attributes... button is only available in Writer's Find dialog. This button displays a
dialog with a series of check boxes to find where a particular attribute has been changed from
the default for the underlying style. E.g. The attribute “Font weight” would find where text
had been made bold where the underlying font was not bold (and vice versa).
Note: The attributes settings remain between uses of the Find dialog. This can be extremely
frustrating, so always turn off all of the attribute settings after use.
2.13.3 Formats
This is the same concept as Microsoft Office. Note that if formats are used there is an option
to include searching within styles. E.g. Searching for bold text would not find bold text
where the style is bold unless this option is checked.
2.13.4 Regular Expressions
“Regular expressions” are significantly different in OpenOffice.org from Microsoft Office's
“Use wildcards”. See Help > Index tab > type in “regular expressions”. Some common
examples are in Table 2. To use regular expressions make sure that Regular expressions is
checked. On reopening the Find / Replace dialog the Regular Expressions check-box is
always unchecked.
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Note: The asterisk “*” means any number of the preceding character so where in Microsoft
Office you might have just “*” the equivalent in OpenOffice.org is “.*” as “.” stands for
any single character (like Microsoft Office's “?”).
Table 2Sample regular expressions

Problem

Search

Replace

Replace multiple tabs with just one tab

\t*

\t

Replace multiple spaces with just one space. “[:space]” finds
both non-breaking spaces and normal spaces but not tabs (help is
currently incorrect). Type a normal space in the replace field.

[:space:]*

Remove leading white space (space or tabs in any combination)
at the start of a paragraph.

^([:space:]|\t)*

Remove trailing white space (space or tabs in any combination at
end of paragraph).

([:space:]|\t)*$

Find paragraphs beginning with the character “a” (the rest of the
paragraph can vary) and replace the whole paragraph with a
blank line

^a.*

To remove a paragraph mark from the end of lines (e.g. when
having pasted text from an e-mail message).

$

Replace paragraph marks with a comma so that there is one long
line rather than many lines.

$

,

To replace commas with a paragraph mark

,

\n

To replace line breaks (shift Enter) with paragraph markers
(Note there is not the ability to have a line break in the replace
field as it gets interpreted as a paragraph marker)

\n

\n

Find the word “the” only (E.g. Don't find “then” or “bathe”).

\<the\>

Find “ing” at the end of a word E.g Reading, writing, but not
singer

ing\>

Find whole word that ends with “ing”. Note there is a space
between the caret and the close square bracket character.

[^ ]*ing\>

Select all numbers at the start of a line where the numbers could
include a period. E.g. 1.1

^[0-9.]*

2.13.5 Similarity Search
The similarity search option is to broaden the search so that what is found doesn't have to be
exactly the same as what was specified in the “Search for”. To specify how different it can be
click on the ... button next to similarity search.
2.13.6 Search for styles
Writer and Calc have an option, Search for styles (changes to Within Styles if Format or
Attribute search is used). Check this first if searching for a particular style. The Search for
combo box field changes to listing the used paragraph styles.
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3 Customizing the Interface
This section is about changing the interface (where changing it in OpenOffice.org is different
from how it would be accomplished in Microsoft Office). The last section is about how to
store to a template any changes to menus, keyboard shortcuts, status bar and toolbars.

3.1 Toolbars
3.1.1 Customizing Toolbars
To get started this is the same in OpenOffice.org as Microsoft Office. On a toolbar right
click > Cutomize... or Tools > Configure... > Toolbars tab > Customize...
However, rather than dragging buttons onto the toolbar from the dialog use:
1) Toolbars drop-down to select the toolbar
2) The Add--> and <--Remove buttons to change which buttons are on the selected
toolbar
3) The checkboxes determine whether the button gets displayed or not
4) Use the Move Up or Move Down buttons to change the order
5) Use Icons... to change the icon displayed (e.g. for a macro)
Note: There is no in-built toolbutton editor. To use a custom icon, save it to the
"{installpath}/share/config/symbol" directory in *.BMP format. OpenOffice.org
automatically searches this directory for new icons each time the Customize Buttons dialog
is opened. Custom icons must be 16 x 16 or 26 x 26 pixels in size and cannot contain more
than 256 colors. (From OpenOffice.org help)
3.1.2 Creating a new toolbar
To create a new toolbar:
•

Tools > Configure... > Toolbars

3.2 Customizing Menus
To customize menus:
•

Tools > Configure... > Menu

To add a function:
1) Select the location in the Menu entries listbox (top one)
2) Select category and function in the bottom list boxes
3) Click New to insert that function into the menu.
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3.3 Keyboard Shortcuts
Styles cannot automatically have keyboard shortcuts. A work-around is to use a macro.
To customize keyboard shortcuts:
•

Tools > Configure... > Keyboard

Microsoft Office requires the user to use a key combination and then click assign. In
OpenOffice.org a list of shortcut keys is displayed in the top listbox. To assign a function to
the desired key combination, select the function using the bottom list boxes and click
Modify.
Note: A key shortcut can be OpenOffice.org wide or just within the current application.

3.4 AutoCorrect/Auto format
A really nice feature in OpenOffice.org is the ability to have exceptions for
AutoCorrect/AutoFormat. E.g. Have the “Correct TWo INitial Capitals” in operation but
exclude situations where two capitals are desired, like OOo.
•

Tools > AutoCorrect/AutoFormat...

3.5 Undo / Redo
To specify how many “undos” are available:
•

Tools > Options... > OpenOffice.org > Memory > Number of steps

3.6 Spell Checking
To set-up the spell check options in OpenOffice.org:
•

Tools > Options... > Language Settings > Writing Aids

The spell check options are consistent across all OpenOffice.org applications.

3.7 Grammar Checking
Currently there is no grammar checking function. To quote the proof reader of this
document: “But this is no great loss. I have reservations about the value of the one available
in Microsoft Word.”

3.8 Security Settings
Virus protection - for macro and Java security settings:
•

Tools > Options > OpenOffice.org > Security
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For other security-related issues see 2.12.6 Password protection and 2.12.7 Privacy Options
on page 10 above.

3.9 Personal Settings
To find out where these customizations are stored use:
•

Tools > Options > OpenOffice.org > Paths

The dialog shows that the information, by default, is stored below a folder called “user”.

3.10 Storing configurations in a template
This section is about how to store changes to menus, keyboard shortcuts, status bar and
toolbars to a template (or document).
1) Create and save the template that is to have the configurations saved into it. Having a
back-up of the template without the configuration changes is probably a good idea
2) Make the desired changes to the configuration. (See 3.1 Toolbars, 3.2 Customizing
Menus and 3.3 Keyboard Shortcuts above). Note any changes that you don't want as
standard, as these will have to be undone
3) Tools > Configure
4) For each type of customization which is to be stored in the template (i.e, for each tab
of the dialog that you want to change), click Save and choose the desired template (I.e,
the one created and saved in step 1)
5) It is OK to overwrite the file – the warning message that is displayed is inappropriate
and can be ignored
6) Undo the changes that are not wanted as standard (as were noted in step 2)
Note: It is a good idea to create a new toolbar (or bars) for the template.
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4 Conversion of Microsoft Office Files
One of the advantages of OpenOffice.org over other office suites that could be a replacement
for Microsoft Office is its ability to read and write Microsoft Office files. However, it is not
perfect. Similarly, Microsoft Office itself is not perfectly able to import / export files from /
to older versions of itself. It is possible to open a Microsoft Office file and save it either in
OpenOffice.org format or re-save it in Microsoft Office format.
Note: If features in OpenOffice.org which are not in Microsoft Office have been used in the
document they will be lost – see 4.4 Import / Export / sharing issues between Microsoft
Office and OpenOffice.org on page 20 below).

4.1 File format
The purpose of this section is to give an overview of file format from an end-users
perspective. For details about XML formats see: http://books.evc-cit.info/book.php.
4.1.1 Philosophy
OpenOffice.org stores its files in a compressed (zipped) human readable (when unzipped)
XML-format. This format is openly documented and is available under the GNU General
Public Library License (http://www.gnu.org).
By contrast, Microsoft Office files are stored in a proprietary format which is not human
readable.
4.1.2 Default File Format
To set the default file format when saving new files:
Tools > Options... > Load/Save > General
Note: If the default is set to an OpenOffice.org format and a Microsoft Office file is being
saved, then a warning dialog will be displayed about potential loss of formatting.
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4.1.3 File Extensions
Table 3: OpenOffice.org file extensions

Document
type

Application

Document Template
Extension Extension

Text

Writer

.sxw

.stw

Spreadsheet

Calc

.sxc

.stc

Drawing

Draw

.sxd

.std

Presentation

Impress

.sxi

.sti

Formula

Math

.sxm

na

Master document

Writer

.sxg

na

HTML document

Writer

.html

na

4.2 Bulk conversion
To convert a lot of files:
File > AutoPilot > Document Converter...
Note: Converting a lot of files can take a long time. Recommend to set it going when the
computer is not going to be used for a while, but check for sufficient disk space.

4.3 Microsoft Office to OpenOffice.org to Microsoft Office
This is where people are collaborating on a document, some in OpenOffice.org and others in
Microsoft Office. In these circumstances the file will regularly be opened in both
OpenOffice.org and Microsoft Office. As Microsoft Office can not open OpenOffice.org
documents the documents will need to be saved in Microsoft Office formats (see 4.1 File
format on page 19 above).
While most things work smoothly between the two, there are some things which don't. See
4.4 Import / Export / sharing issues between Microsoft Office and OpenOffice.org below and
issues in each of the chapters on applications.

4.4 Import / Export / sharing issues between Microsoft
Office and OpenOffice.org
4.4.1 Object Linking and Embedding (OLE)
To change the settings for Microsoft Office OLE objects:
Tools > Options > Load/Save > Microsoft Office
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Having all of these options checked will allow embedded objects to be converted and thus be
editable in both office suites.
For other OLE objects, it will depend on the machine where the file is being edited just as it
does with Microsoft Office alone. Thus Windows application based OLE objects will not be
editable in OpenOffice.org on a Linux machine. The object will still be displayed correctly
and is able to be resized.
4.4.2 Linked files
Cells copied from Excel and pasted special, linked and with RTF format, into Word are
imported into Writer as a normal table. This means that when the document is imported, the
link to the Excel file is lost.
Similarly when a chart copied from Excel and pasted special, linked into Word, and then the
file imported into Writer, the chart is imported as an embedded OLE object but is not
converted into a Calc chart. On saving the file in Word format and then opening the file in
Word and trying to edit the chart by double clicking it displays an error message.
Warning: The links are lost!
4.4.3 Word Art / Fontwork
The equivalent to Microsoft Office's Word Art in OpenOffice.org is Fontwork. These are
imported /exported as graphics so the ability to edit them is lost. See 10 FontWorks
(WordArt equivalent) on page 67 below.
4.4.4 Vector graphics
The basic shapes: lines, arrows, rectangles, ovals all import / export without problem.
OpenOffice.org provides greater degree of control over some properties than Microsoft
Office so sometimes there will be changes when going from OpenOffice.org to Microsoft
Office. E.g size of arrow heads, line styles.
The Microsoft Office autoshapes, like the smiley face, lose their special characteristics, like
adjusting the degree of the smile / frown.
Microsoft Office provides more shadow options than OpenOffice.org so sometimes there
will be a change in shadow appearance. Microsoft Office shadow styles 1, 2, 4, 6,14, 17 and
18 are supported in OpenOffice.org. Horizontal and tapered shadows do not get imported.
On exporting documents containing graphics, such as callouts, the locations frequently
change.
4.4.5 Frames / text boxes
When importing frames or text boxes from Microsoft Office to OpenOffice.org with linked
text the links do not remain.
4.4.6 Active content controls
These are the controls in Microsoft Office available on the Controls toolbar.
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Check-boxes, radio buttons, text fields, labels, list-boxes, combo-boxes, Toggle buttons, all
import without a problem. But as these controls typically require macros to be of use they
will be functionally useless.
Scrollbars and images import as OLE objects.

4.5 Macros
OpenOffice.org can not run Microsoft Offices macros. While the macro language is very
similar the underlying objects are quite different. The following settings (Tools > Options...
> Load/Save > VBA properties) are for opening Microsoft Office files and what to do about
their macros.
Note: Opening a Microsoft Office file infected with a virus is quite safe in OpenOffice.org.
There is the ability to record macros in OpenOffice.org. The recorder uses something called a
dispatcher whereas it is better practice to use the application program interface (API).
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5 Text Documents
This section deals specifically with Word and Writer.

5.1 Interface differences specific to Word / Writer
Vast chunks of this section have been copied from (with minor changes only) a document by
Jean Hollis, titled “OpenOffice.org for Microsoft Word users”. The full document is
available for download from: http://www.taming-openoffice-org.com/index.htm.
5.1.1 Views
Word has 4 views (depending on version) called:
Normal: Recommended view (by Microsoft) for doing most of your typing and editing.
Writer has no real equivalent view.
Page or Print Layout: Shows the document (more or less) as it will print. This is the closest
equivalent to the main view in Writer.
Online Layout: In theory shows the document as if viewing it on-line. Writers equivalent is a
view option called Online Layout.
Outline View: For working with heading hierarchies. Writer has the Navigator.
Writer also has an HTML source view when working on HTML files.
Writer displays less information about the field with view fields turned on than Word. To get
detailed information need to right click the field > Fields... (or select field > Edit > Fields...)
5.1.2 Status bar
The status bar if similar to Words except it does not show the current location of the cursor
on the page (row number and number of characters across). It does however show the
position within a table in spreadsheet style format, I.e Top left cell =A1.
5.1.3 Navigator
Word doesn't have a similar concept to the Navigator and, in the author's opinion, it is such a
useful tool it is worth taking the time to learn more about it. Press Shift + F1 and hover over
each of the buttons to get a detailed description of what they do.
List Box on/ off refers to the drop-down list box at the bottom of the navigator. With this list
box it is possible to select any of the open Writer documents so that their contents are
available for dragging and dropping (what happens when dropped being determined by the
drop mode specified using the Drop Mode button).
Note; Graphics, indexes,OLE objects and references cannot be dragged and dropped when
in the Insert as link or Insert as Copy modes.
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5.1.4 Stylist
For a more detailed guide on using styles see: 5.1.12 Use templates and styles on page 32
below.
Use Shift + F1 to check out the different buttons on the stylist. Use the bottom list box to
change the style group that is displayed. E.g. Applied styles only shows those styles that have
been used in the document.
5.1.5 Keyboard
When some text has a character attribute at the end of a paragraph (say bold or a hyperlink)
but the new text doesn't require that attribute then press the right arrow key before typing.
Deleting paragraph marks: pressing Delete at the end of a paragraph effectively moves the
text of the following paragraph into the current. I.e The paragraph formating of the top
paragraph remains. Pressing Backspace at the start of a paragraph and the format of the
lower paragraph remains
Hint: An aid to remember this is: the format of the paragraph that has the cursor will be the
format of the combined paragraph. Except if the current paragraph is empty backspacing
will leave the previous paragraph's formatting.
Control + Home when in tables: In Word Control + Home always positions the cursor to the
top of the document, in Writer Control + Home first positions the cursor at the start of the
cell, then the start of the table and then the start of the document. Similar concept for
Control + End.
Control + Alt + Up or Down: when not in a table moves the current paragraph up or down.
How to select multiple parts of the text?
To copy, cut, format or delete parts of the text in different areas of the document use:
•

Control + selection with one click, double click or sliding.

or
•

Click once on the field "STD" (STanDard) in the status bar

•

The field now shows "EXT" (EXTended selection)

•

Another click and it changes to "ADD" (ADD to selection).

Note: the ADD mode is the equivalent to Control + click and EXT is equivalent to Shift +
click.
Multiple selections and tables
The following limitations apply when selections involve tables:
•

It is possible to have multiple selections within a cell, but only one selection is possible
that involves more than one cell

•

A selection that starts in a table can not extend beyond the table
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•

A selection that starts outside a table will include the entire table (I.e., can not have a
selection that starts outside a table and also contains a portion of a table)

Comparison of key short-cuts
Table 4: Word v Writer different default key shortcuts (incomplete)

Function

Word standard
shortcut

Writer standard
shortcut

Underline words not spaces

Control + Shift + W

No equivalent

Change font size

Control + Shift + P

No standard equivalent

Thesaurus

Shift + F7

Control + F7

Show/hide non-printing
characters

Control + Shift + *

Control + F10

Hanging Indent

Control + T

No standard equivalent

“Unhang” Indent

Control + Shift + T

No standard equivalent

Indent

Control + M

No standard equivalent

“UnIndent”

Control + Shift + M

No standard equivalent

Superscript

Control + Shift =

Control+Shift+P

Subscript

Control + =

Control + Shift + B

Remove character formatting

Control + Spacebar

Right click > Default

Remove paragraph formatting

Control + Q

No equivalent

Jump to previous edit point

Shift + F5

Need to use the reminders
on the Navigator

Shift paragraph up

No equivalent

Control + Up

Shift paragraph down

No equivalent

Control + Down

5.1.6 Mouse use
Some differences are:
•

Right click displays context but for the current cursor position not the pointer position

•

No quick selection of rows or columns in tables

•

Triple click selects current line or current cell when cursor in a table

•

No quick selection of paragraphs or lines by clicking to the left of the paragraph

5.1.7 Tables
The menu option to insert a table is in the Insert menu. The other menu options for tables are
are in the Format menu (rather than having their own menu). The menu options and Tables
object toolbar become visible when the cursor is in a table.
Tables are like one special paragraph so when selecting text using the keyboard (Shift +
arrow) from, say, above the paragraph the whole table is selected then the line below it.
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Tables without borders can be hard to spot – they don't have a thin gray line like tables in
Word.
The page formatting of long skinny tables into newspaper style columns when the table
crosses a page break appears to be unreliable.
Header Rows
By default new tables have a header row.
To have more than one row for a header row (copied from help):
1) Select the first row of the table
2) Right-click and choose Cell - Split
3) In the Split area, enter the number of rows that you want to include in the header.
4) In the Direction area, click in the Horizontally box. If you want the rows to have
equal heights, select the Into equal proportions check box
5) Click OK
To turn off header rows
Simply delete the rows. To keep the contents of the header rows, insert the required number
of rows, copy and paste the heading rows into the new rows, then delete.
Adjusting column widths and row heights using the keyboard
Use the 3 buttons on the Table object toolbar to set what happens to the overall width of the
table:
•

Table: Fixed: Overall width of the table stays the same, but the adjoining column shrinks
or grows correspondingly

•

Table: Fixed Proportional: The current column and the end column change by
corresponding amounts, keeping the overall width the same

•

Table: Variable: Only the current column changes so the overall width of the table
changes

Use Alt and the arrow keys as follows to adjust the width of columns (or height of rows)
•

Alt and arrow keys adjusts the right side (bottom for rows)

•

Alt + Shift and arrow keys adjusts the left side (top for rows)

•

Alt + Control + left or right arrow keys adjusts the current cell only

Copying and pasting
Writer never inserts new rows or columns when pasting data – it always overwrites the
contents of the cells. This makes it clear as to what will happen. To avoid overwriting cells
insert the required number of rows or columns first.
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Inserting and deleting rows or columns
Inserting is always below for rows and to the right for columns (opposite of word).
Note: This is a surprising inconsistency as Calc inserts above and to the left.
To insert rows or columns using the keyboard: Alt + Insert, arrow key. To delete rows or
columns using the keyboard: Alt + Delete, arrow key. The insertion or deletion is in the
direction of the arrow key. E.g. Alt + Insert, Up inserts a row above the current row.
Equal row heights and column widths
On the Tables object toolbar there is a long click button called Optimize, this presents a tearoff menu for easily adjusting row heights and column widths to being the same.
Splits and merges
To merge cells – like Word always do this last.
To split or merge cells: Select cells to be merged then Format > Cell
To split a table (horizontally) Format > Split Table
To join two tables they need to be one below the other then Format > Merge Tables, if there
is a table above and below the current table the user will be prompted which one they wish to
join.
To prevent accidental change to cell contents
To prevent accidental change to cell contents: Select the cells, Format > Cells > Protect.
This is not a security feature as the cells aren't password protected but does prevent
accidentally changing a cell.
Sorting
To sort a table:
1) Select the cells to be sorted don't include the headings. The option to sort only
becomes available when there is something selected.
2) Tools > Sort
Unlike Word the sort dialog uses column number rather than the names of the column.
Entering numbers and formulas
Unlike Word, tables in Writer can work much more like spreadsheets, for example calculated
values change as the data is input (no more selecting and pressing F9 to update calculated
results).
With number recognition turned on when entering a number Writer will automatically format
the number according to a specified number format. To change this behavior right click when
the cursor is in a table > Number Recognition.
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To change the number format: Select the cells, Format > Number Format...
To enter a formula like sum:
1) Select the cell where the result is to go
2) Press F2 to display the Formula bar
3) Click and hold Formula button to display formula menu
4) Select desired function (list separator is for separating constants e.g. =mean 5 | 12 | 20)
5) Click and drag on cells to input ranges
6) Press Enter to finish
To enter a formula like this cell plus that cell minus that cell
1) Select the cell where the result is to go
2) Press F2 to display the Formula bar
3) Click on a cell
4) Type or select the desired operator
5) Click on the next cell
6) Repeat steps 4 and 5 until done
7) Press Enter to finish
Creating a table from a data source
To create a table from a data source:
1) Display the Data source viewer (F4)
2) In the Data explorer window navigate to the desired table or query
3) Drag the name of the table or query into the document
4) Select the desired fields and set other properties as required in the dialog
5.1.8 Charts in Writer
Charts copied from a Calc spreadsheet and pasted into a Writer document are, by default
embedded objects. Unlike doing this in Microsoft Office only the relevant data for the chart
is embedded. In Microsoft Office copying and pasting a chart also embedded it, but if the
Excel workbook was 8 mb in size (not unrealistic for a spreadsheet) then each chart pasted
into a Word document would increase the Word document by 8 mb.
Linking of charts does not exist except in the Windows version (author hasn't tested this in
Windows for OpenOffice.org 1.1.1).
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5.1.9 Customizing the user interface
Most functions are found in similar places in both programs, but a few are slightly different,
and the degree of control varies. This table summarizes where to find the setup choices.
Table 5: Customizing the user interface

To do this...

In Word...

In Writer...

Change measurement system

Tools > Options... > General

Tools > Options... > Text Document
> General

Turn off Autocompletion

Not applicable

Tools > autocorrect. In the “Word
completion” tab, untick Word
Completion.

Turn on/off Help Agent

Help > Microsoft Word Help
> Options

Help > Help Agent

Set up document window (rulers,
status bar, default toolbars, etc)

View > select required items

View > select required items

Customize toolbars

Tools > Customize

Tools > Configure

Customize menus

Tools > Customize

Tools > Configure

Display font names in their font
(in toolbar drop-down font list)

Tools > Customize >
Options

Tools > Options > OpenOffice.org
> View, select Preview in fonts lists

Always show full menus
(include unavailable and littleused items)

Tools > Customize >
Options

Tools > Options > OpenOffice.org
> View, select Inactive menu items

Show/hide ScreenTips
(ToolTips) on toolbars

Tools > Customize >
Options

Help > Tips to uncheck

Always create backup copy

Tools > Options > Save

Tools > Options > Load/Save >
General

Autosave every x minutes

Tools > Options > Save

Tools > Options > Load/Save >
General

Show paragraph marks, tabs, etc.

Tools > Options > View

Tools > Options > Text Document
> Formatting Aids

Change file locations

Tools > Options > File
Locations

Tools > Options > OpenOffice.org
> Paths

Change user information

Tools > Options > User
Information

Tools > Options > OpenOffice.org
> User Data

Set up AutoCorrect and
AutoFormat options

Tools > AutoCorrect
Options

Tools > AutoCorrect/AutoFormat
> Options
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5.1.10 Write, edit, and review documents
Most writing, editing, and reviewing techniques in OOoWriter are similar to those in
Microsoft Word, but the details often vary.
Table 6Write, edit and review documents

To do this...

In Word...

In Writer...

Jump quickly to other parts of a
document

Edit > Go to

Edit > Navigator, (or F11) doubleclick on required heading, figure,
table, etc.

Choose language for spelling
checker

Tools > Language > Set
Language

Tools > Options > Language
Settings > Language. (Note:
OpenOffice.org has no grammar
checker)

Ignore some text when checking
spelling

Select text; Tools >
Language > Set Language >
Do not check
(or) Format > Style >
Modify> Format > Language

Select text; right-click > Character
> Font > Language = [None] or the
real language of the selected text, if
that is foreign.

Recheck spelling

Tools > Spelling &
Grammar > Recheck
Document

Always rechecks

Find and replace text, formatting,
and styles

Edit > Replace > More;
choices as needed

Edit > Find & Replace; details are a
bit different

Use wildcards in find and replace

Edit > Replace > More >
select Use Wildcards
checkbox

See 2.13.4 Regular Expressions on
page 14 above.

Choose, create, or edit a custom
dictionary

Tools > Options > Spelling
& Grammar > Custom
Dictionaries

Tools > Options > Language
Settings > Writing Aids

Create exception (exclude)
dictionary

File > New, type words,
Save As > text only, file
extension .EXC

As for custom dictionary, but select
Exception [-] checkbox

Track changes (choose options)

Tools > Options > Track
Changes

Tools > Options > Text Document
> Changes

Protect document for editing

Tools > Protect Document

Edit > Changes > Protect Records
(Password needs to be at least 5
characters)

Mark and track changes

(Word 2000) Tools > Track
Changes > Highlight
Changes

Edit > Changes > Record

Insert comments associated with
a change

Highlight text; Insert >
Comment

Edit > Changes >Comment

Insert notes (comments not
associated with a change)

Highlight text; Insert >
Comment

Insert > Note

Show changes as pop-up text

Options > View > Screentips

Help > Tips (and) Help >
Extended Tips
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To do this...

In Word...

In Writer...

Merge documents

Tools > Merge Documents

Edit > Changes > Merge
Document

Accept or reject changes

View > Toolbars >
Reviewing

Edit > Changes > Accept or Reject

Change document properties

File > Properties

File > Properties

Get a word count

Tools > Word Count (can
get word count for selection)

File > Properties > Statistics tab
(Cannot get word count for
selection.) or use the wordcount
macro at Darwinwars. This does
selections, and will do footnotes for
1.1. Large selections will be slow,
though, until the scripting
framework is complete.

Create AutoText entry

Select text; Insert >
AutoText > New

Edit > AutoText (or) Control + F3

Insert AutoText

Type shortcut and press F3

Type shortcut and press F3; or type
Name and press return. Writer
distinguishes between the “name”
and the “shortcut” of an autotext.
Word does not.

AutoText in Writer always ends with a paragraph mark. So for a short in-line shortcut better
to use AutoCorrect.
5.1.11 Control page layout
This section covers such things as margins, headers, and footers.
Writer and Word have somewhat different notions of page layout.
Word notion of page layout
Page layout is a property of the document as a whole. If you change the page layout (for
instance, set the document to landscape), it changes for the entire document. You can then
arrange for specific sections to have a different layout.
Writer notion of page layout
Page layout is a property of the page style. For example, First Page, Index and Default. If you
change the page layout for one page style (for instance, set Default to have a header with
page numbers) only that style will be affected.
Using page styles gives Writer some very useful features. For instance, you can define the
First Page page style so that, after you have typed the first page, the style switches to Index.
You can then set Index so that it is followed by Default.
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Comparison for page layout
Table 7: Control page layout

To do this...

In Word...

In Writer...

Define margins

File > Page Setup > Margins

Format > Page >Page

Specify different headers and
footers on first, odd, and
even pages

File > Page Setup > Layout >
Headers and Footers section

Define different page styles for
First, Left (even), and Right
(odd) pages, using Header and
Footer tabs

Edit headers and footers

View > Headers and Footers, then
type or insert fields; can also
double-click in existing header or
footer regions

After you have specified Header
and Footer areas for a page, they
are always active. Single-click to
type or insert fields

Change from roman to arabic
page numbers in the footer
of a page

Insert a section break, deselect
“Same as Previous” in the second
section, define a new footer with
page numbers restarting at 1 in
arabic numerals

Insert a manual page break and
apply a different page style

Use paragraph styles for
page layout

Can define paragraph styles with
offset from left margin, with
heading styles aligned left or right

Can define paragraph styles with
offset from left margin, with
heading styles aligned left or
right

Use columns for page layout

Insert continuous sections to switch
from single to multiple columns on
one page

Format > Page > Columns (or)
Insert/Format > Section >
Columns (or) other methods

Use frames or text boxes for
page layout

Frames are used in Word 97 but
mostly replaced by text boxes in
Word2000 and 2002; can be linked
to flow text from one to next, as in a
newsletter

Insert > Frame (can link frames
to flow text from one to next, as
in a newsletter); “text boxes” are
fields, not positioning devices

Use tables for page layout

Table > Insert > Table (use dialog to
format)

Insert > Table (use dialog to
format)

Put portrait headers on
landscape pages

Use rotated text box linked to
header

Use rotated text in a frame

Set first page number to
greater than 1

Insert > Page Numbers > Format

See 5.4.7 Page numbering on
page 39 below

View and edit facing pages

File > Print Preview; click Zoom
button to enable editing

File > Page Preview; cannot edit
when previewing

5.1.12 Use templates and styles
Table 8: Use templates and styles.

To do this...
Find which template is
associated with a document

In Word...
Tools > Templates and Add-ins
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To do this...

In Word...

In Writer...

Specify default template

"Normal" template is default

File > Templates > Organize lets
you set any template as default

Create a new template

File > Save As, set type to
Document Template (.DOT)

File > Templates > Save

Edit a template

File > Open, choose template

File > Templates > Edit

Copy styles between templates

Tools > Templates and Add-ins >
Organizer

File > Templates > Organize.
There, you copy styles with drag
and drop between templates and
documents.

Create a new document from a
template

File > New (opens a list of
templates)

File > New > Templates and
Documents

Apply a different template to a
document

Tools > Templates and Add-ins >
Attach, select template, Open

Start a new document based on
the different template; copy
contents of old document into new
document.

Apply a style to text

(Word 2000) Select from Style
List or Style dialog
(XP) Can also use task pane.

Format > Styles (or press F11),
double-click style in list; after one
use, paragraph styles appear in
Apply Style list on Formatting
object bar.

Change a style definition

(Word 2000) Format > Style >
Modify; (XP) can also select in
task pane and click Modify

Select style in Stylist, right-click,
choose Modify; or Format >
Styles > Catalog, select style,
click Modify.

Create a new style

Format > Style > New

Format > Styles > Catalog, click
New or Right click in Stylist New.

Use outline numbering

Format > Style, select style >
Format > Numbering

Tools > Outline Numbering

Drop caps

Format >Drop Cap...
One character only, can not be
part of a style.

Format > Paragraph > Drop Caps
Drop caps are able to be part of a
style. Can be >= 1 char or word.

Font size
When a style is based on another style it is possible to set the font to being a percentage of
the font size in the original style. In the font size field simply type the number followed by a
percentage sign, e.g. 120%. This way changes to the underlying style will be better reflected
in this style. To change it back to being an absolute font size type the number followed by the
characters “pt”, e.g. 12pt.
Space between paragraphs and page breaks before
In Writer paragraph properties are more intelligent than Word. Specifically:
•

Space before if at the top of a page is ignored

•

Space between paragraphs the greatest of space above and space below for the two
paragraphs is applied
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•

Page break before if at the top of a page doesn't create a blank page

This makes using styles possible without having to apply direct paragraph to fix issues
afterwards.
Numbering and styles
A better approach to numbering in Writer:
1) Create a numbering style
2) Create a second numbering style with the same settings as that created in step 1 but
with numbering starting at 1
3) Create a style for the numbered paragraphs using the numbering style created in step 1
4) Create a style for the first numbered paragraph based on the style created in step 4 but
with the numbering style created in step 2, and next style being set to the style created in
step 3
5) Create a style for the paragraph that precedes a numbered list with next style property
set to the style created in step 4
6) To use this, simply apply the style that precedes a numbered list (that created in step 5)
then pressing enter at the end of each line will automatically apply the numbering and
styles
Note: There is a bug (author's opinion) in Writer that means that applying outline
numbering of the form 1.1.1 using numbering styles doesn't work. The work-around is to use
the heading styles but apply outline numbering by: Tools > Outline Numbering...
For more detailed guides on using styles see:
http://www.math.umd.edu/~dcarrera/openoffice/docs/Chapters/Styles.pdf or
http://documentation.openoffice.org/HOW_TO/word_processing/01en.sxw.
5.1.13 Use fields
Table 9: Use of fields

To do this...
Insert a field

In Word...
Insert > Field

In Writer...
Insert > Fields

(or) CTRL+F9 for blank
field
Define a number range field

Insert > Field, use SEQ
(sequence)

Insert > Fields > Other >
Variables > Number range

Insert a bookmark

Select text; Insert >
Bookmark

Select text; Insert > Bookmark

Insert a cross-reference to a
bookmark

Insert > Cross Reference,
choose Bookmark as type

Insert > Cross Reference >
Bookmark
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To do this...

In Word...

In Writer...

Insert a cross-reference to a
heading

Insert > Cross Reference,
choose Heading as type

Either bookmark the heading or use
Insert > Cross Reference > Set
Reference to mark the heading, then
Insert > Cross Reference > Insert
Reference.

Insert a cross-reference to a
figure or table

Insert > Cross Reference,
choose type

Insert > Cross Reference > Insert
Reference > Figure (or Table)

Use conditional content

Use IF or other fields, or
styles (all workarounds)

Insert > Fields > Other >
Variables (among other ways)

5.1.14 Work with large or complex documents
Major differences exist in the use of master documents. The table does not attempt to
summarize all these differences.
Table 10: Work with large or complex documents.

To do this...

In Word...

In Writer...

Create a table of contents, list of
figures, or an alphabetic index

Insert > Index and Tables

Insert > Indexes and Tables >
Indexes and Tables

Insert index entries

ALT+SHIFT+X

Insert > Indexes and Tables >
Entry (or) click Insert Index
Marker icon

Create a bibliographic database

Need to use other package

Tools > Bibliography Database

Insert bibliographic references
into text

Link to field in database

Insert > Indexes and Tables >
Bibliographic Entry

Insert footnotes and endnotes

Insert > Footnote

Insert > Footnote (or) click Insert
Endnote Directly icon

Insert other files

Insert > File, choose Insert
or As Link

Insert > File

Cross-reference between
documents

Use Includetext fields

Currently have to remember the
name of the set reference. Reference
will show correctly when in master
document.

Use master documents

Not recommended

File > Send > Create Master
Document; use Navigator to insert
subdocuments

5.1.15 Work with graphics
Most graphics work should be done outside Word or Writer, with the graphic files embedded
or linked to the Word or Writer file. However, you can do some simple graphics using the
drawing tools in Word or Writer. This table covers the basics.
Table 11: Work with graphics.
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To do this...

In Word...

In Writer...

Create Drawing objects

(Word 2000) View > Toolbars >
Drawing; (XP) Insert > Picture >
New Drawing

Click Show Draw Functions icon

Combine graphics objects and
drawing objects

(Word 2000) Edit > Picture >
Reset Picture Boundary; (XP) Use
drawing canvas

Place all objects in a frame

Insert graphics files into a
text document (embed or
link)

Insert > Picture > From File,
choose Insert or As Link

Insert > Graphics > From File

Anchor graphics

Format > Picture > Layout >
Advanced > Picture Position

Use icons on Graphics object bar,
or right-click and choose from
pop-up menu, or click Format >
Graphics

Wrap text around graphics

Format > Picture (or Object) >
Layout

Use icons on Graphics object bar,
or right-click and choose from
pop-up menu, or click Format >
Graphics > Wrap

Crop graphics

Format > Picture > Crop, (or) click
Crop tool on Picture toolbar

Format > Graphics > Crop
(No tool for dragging crop area)

Create captions for graphics

Select graphic; Insert > Reference
> Caption

Select graphic; Insert > Caption

Annotate graphics

Use drawing objects; group, or
place in frame or on drawing
canvas (XP)

Place all objects in a frame

Insert watermark

Format > Background > Printed
Watermark > Picture (or Text)
Watermark

Format > Page Style >
Background
(or) create drawing object,
Arrange > To Background,
Anchor > To Page

5.2 Good practice in text documents
Some issues can be avoided simply by using good word-processing practice:
•

Use character and paragraph styles rather than direct formatting

•

Use paragraph formatting for space before and after rather than hard returns- particularly
in numbered or bulleted lists

•

Use paragraph text flow properties (e.g. keep with next) rather than using manual page
breaks

•

Do not use multiple tabs or spaces to align text – either set specific tab stops or better yet
use a table

•

Use only commonly available fonts.
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5.3 Compatibility settings in OpenOffice.org for the current
document
The following settings change the way OpenOffice.org works with the current document so
that it works more like Microsoft Office.
•

Use: Tools > Options... > Text Document > General

5.3.1 Tops of pages
In Writer, if this setting isn't checked, if a paragraph at the top of the page (or column) is
formatted with space above then it is ignored whereas in Word it offsets it. Checking this
option causes Writer to behave in the same way as Word.
5.3.2 Aligning Tabs
Specifies whether centered and right-aligned paragraphs containing tabs are formatted as a
whole in the center or aligned to the right. If this field is not marked, only the text to the right
of the last tab is aligned to the right, while the text to the left remains as is. (From help)
5.3.3 Spacing between paragraphs
Writer uses the greater of the two spacings for above and below paragraphs, Word sums the
two together. Check this box to behave in the same way as Word.

5.4 Import / Export issues between Writer and Word
The following summaries of issues with working between Writer and Word are based upon
the author's experience. These issues will require regular updating as both packages change.
5.4.1 Font and Font spacing
Text effect animations are not imported by Writer from Word files.
Hidden text in writer is a field, whereas in Word it is a font attribute.
Typically Word's character spacing is tighter than Writers, so often Word will fit more
characters to a line. It is also possible that the spacing between lines could be slightly
different. The end result is that the page breaks maybe in different places.
5.4.2 Tables
Writer doesn't allow a row within a table to be split across pages. Word (by default) allows a
row to be split across pages.
Writer doesn't support vertical text within a cell.
Warning: There is a vertical option for formatting text (Format > Character... >
Rotation / Scaling) for some reason that the authors haven't figured out this is
not recommended for using in a table see:
http://www.openoffice.org/issues/show_bug.cgi?id=16944.
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If it is used in a table in a document and that document gets exported to Word
then Word goes into a loop perpetually trying to re-paginate the document.
Text in a table with vertical alignment imported from Word - the vertical text simply
becomes horizontal.
Fields for calculations within tables are imported as the text of the saved result. I.e. The field
for performing the calculation is lost.
Summary: Documents containing Tables can be imported and exported between
OpenOffice.org and Microsoft Office but they cannot contain vertical text and be aware of
the large row spanning pages issue.
5.4.3 Mail merge documents
As OpenOffice.org and Writer have different approaches to data sources on importing a
Word document that is the main document for a mail merge there is no connection with the
data source. It is not just a matter of making that connection, each field needs to be
reinserted. See 5.5 Mail Merge on page 41 below.
Also in Word you can have another Word document as a data source for a mail merge. There
is no way of specifying a Word (or Writer) document as a data source in OpenOffice.org.
Writer doesn't have the option of suppressing blank lines when data fields are empty so need
to use conditional fields. See 5.5.5 Eliminating blank lines on page 42 below.
Writer merge fields export as text with the name of the field between angle brackets, e.g.
<Name>.
Summary: To work in a shared environment would require a separate file for each “main
document” one in Word format the other in OpenOffice.org format.
5.4.4 Forms
Issues with forms created in Microsoft Office:
A locked file in Microsoft Office imports unlocked into OpenOffice.org I.e in design mode.
Text form fields import into OpenOffice.org as Input fields and so lose their type. I.e a text
form field of type number or date will accept any text for input. In use a text form field in
OpenOffice.org displays a dialog for entering the text. Exporting back to Microsoft Office,
text form fields are changed into “Fillin” fields. The current date and time and calculation
fields import as simple text.
Check-boxes import/export ok.
Drop-down form fields import as Input List fields. Like text form fields in operation these
display a dialog from which the user can select an option. On export back to Microsoft Office
they return to drop-down form fields again.
Issues with forms created in OpenOffice.org:
The controls are exported as active controls when there is a Microsoft Office equivalent. As
Word doesn't have the same database functionality of OpenOffice.org and as the macros
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aren't compatible it would be very difficult to have the one form that works in both
environments using standard form controls.
Summary: To work in a shared environment with forms is not easy but one work around
would be to use other fields like Input field and Input List. To insert these fields use: Insert >
Fields > Other... > Functions.
5.4.5 Footnotes, end notes, tables of contents and indexes
Footnotes, endnotes and indexes all import / export ok. Some issues found:
•

The location of the endnotes may change (in Word the endnotes were placed before the
index. In Writer they are always at the end of the document)

•

Writer bibliographic entries become text in Word

•

A three column index exported from Writer to Word as three columns but on re-import it
was one column

•

On importing a Word file containing index entry fields, the index entry fields are imported
but as fields to the left of the text rather than the field containing the text

Summary: Working in a shared environment is possible with some minor issues
5.4.6 Numbered paragraphs, outline numbering, cross-references
1. Import / Export without a problem, except for references to numbered paragraphs:
•

Cross-references to the numbers of numbered paragraphs that aren't numbered using
outline numbering don't work as Writer doesn't have this ability

•

Writer also doesn't have the ability to use relative numbering in its cross-references to
numbers

•

Cross-references to chapter numbers don't have the same format as that displayed

5.4.7 Page numbering
A quick and dirty approach in Word for having a different first page (like a cover page) and
then to have the numbering start on the second page but numbered as page 1 is to have a
layout of different first page and setting the starting page to be zero. Unfortunately, on
importing such a file into OpenOffice.org the page number on the second page is two instead
of one. To fix this problem in Writer use:
1) Create a page style for how the pages after the first page should look, name it for
example Convert1
2) Have the cursor in the first paragraph of the second page
3) Format > Paragraph > Text Flow
4) In the breaks portion of the dialog, the check box enable will be checked
5) Check With Page Style
6) Chose the page style created in step 1
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7) Leave the position as before and set the page number to 1
On exporting this document back to Word it will work, the only difference being that the
document will have a section break at the end of the first page. Documents created with
section breaks like this in Word will work fine importing and exporting with Writer. There is
one difference with Word there will now be a blank page between the cover page and the
next page when printed (or print previewed).
Summary: For some documents a little work maybe required to fix up the page numbering on
importing to Writer. Once “fixed” the page numbering of the documents will import/export
without a problem.
5.4.8 Date and time fields
Word's CreateDate and SaveDate fields don't get imported with the same formats. E.g. If the
fields in the Word document have a format that includes time then this information is not
displayed by default. To include time in the format:
Right click on the field > Fields... > scroll to the bottom of the formats listbox > Additional
formats... > in format code add HH:MM:SS
On export the SaveDate / DocInformation:Modified is exported as text.
Writer's Time Fixed and Date Fixed fields get exported as text.
5.4.9 Importing Word Fields
Table 12: Imported Word fields conversion

Word Field:

Writer converts to:

ASK

Input field

AUTHOR

DocInformation:Created

AUTONUM

Number Range AutoNr

AUTONUMLGL

Number range AutoNr

AUTONUMOUT

Number range AutoNr

COMMENTS

DocInfomation:Comments

CREATEDATE

DocInformation:Created

DATE

Date

EDITTIME

DocInformation:Modified

FILENAME

File name

FILLIN

Input field

HYPERLINK

(as a hyperlink)

INFO xxx

DocInformation:xxx

KEYWORDS

DocInformation:Keywords

LASTSAVEDBY

DocInformation:Modified

MACROBUTTON

(the name of the macro?)
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Word Field:

Writer converts to:

MERGEFIELD

Mail merge fields (displayed as the name of the field)

MERGEREC

Record number

NEXT

Next record

NOTEREF

Show variable

NUMCHARS

Statistics (with select = Characters)

NUMPAGES

Statistics (with select = Pages)

PAGE

Page numbers

PAGEREF

Bookmarks (displayed as name of bookmark)

REVNUM

DocInformation:Document number

SAVEDATE

DocInformation:Modified

SEQ

Number range

SET

Set variable

SUBJECT

DocInformation:Subject

TEMPLATE

Templates

TIME

Date

TITLE

DocInformation:Title

TOC

(Displays the table of contents)

The following fields are not imported into OpenOffice.org only the text that they displayed
when last saved: =, IF, DOCPROPERTY, FILESIZE, LINK, LISTNUM, QUOTE,
SECTION, SECTIONPAGES, STYLEREF, TOA, USERADDRESS, USERINITIALS,
USERNAME
The following fields are ignored on import:AUTOTEXT, AUTOTEXTLIST, BARCODE,
BIDIOUTLINE, DOCVARIABLE, EQ, GOTOBUTTON, INCLUDETEXT, LISTNUM,
MERGESEQ, PRINT, RD, SKIPIF, SYMBOL, TA, TC.
The Word field EDITTIME is mapped to Writer field DocInformation:Modified on import
but the meaning has changed to the date and time last saved rather than how long the file has
been open for editing.

5.5 Mail Merge
A lot of this section is based upon a “howto” written by Sophie Gautier, titled “How to do a
“mail merge” from a Calc spreadsheet”. The original is at:
http://documentation.openoffice.org/HOW_TO/word_processing/writer2_EN.html.
5.5.1 Creation of the Mail Template (main document)
1) In Writer with a document that is going to be the mail template
2) Save the file but don't close it
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3) View > Data Sources (or hit the F4 key) The registered data sources will be displayed
in the Data-source viewer
4) Select the source of data for the mail merge. Click on the little cross, next to the data
source name, to display its content tree. Clicking on the name of a table, to see displayed
the fields and their records in the right side of the Data-source viewer. See 12.1.1
Registering the data source on page 70 or 12.2 Creating a data-source from a spreadsheet
on page 72 below for information on registering a data source.
5.5.2 To add the fields into your document:
Click and drag the desired fields (one at a time) to the desired places in your document.
5.5.3 Selecting records for the merge
To select a record, click on the gray rectangle displayed to its right. A small arrow will be
displayed and the record will be highlighted.
To select records that are not consecutive, hold the Control key down while making
selections.
Note: For selecting records based on a criteria see 12.1.5 Using queries to select records on
page 72 below.
5.5.4 Viewing merged data
To see your document as it will be when merged click Data to fields button
To view different records simply select the records in the data source viewer.
5.5.5 Eliminating blank lines
If a field might be blank then the process to suppress the potentially blank line is:
1) Place the cursor before the field in the mail template
2) Control+F2 (or Insert > Fields > Other... ) to open the fields dialog window
3) Switch to the Functions tab
4) Select the field style Hidden Paragraph and type in the Condition area “not(field
name)”
5) Click on the 'Insert' button to insert the function into the document.
5.5.6 Merging
1) Click the mail merge button
2) Choose whether to use all the records, the currently selected records (option becomes
available when records are selected (see 5.5.3 Selecting records for the merge above)
3) Choose whether to send the merge to printer or file. When sending to file a separate
file is created for each record, the files are named according to your options but with an
appended number to ensure that they are unique
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5.5.7 Mailing Labels
The easiest way to create mailing labels is:
1) File > New > Labels
2) Select database from the list of registered databases (see 12.1.1 Registering the data
source on page 70 or 12.2 Creating a data-source from a spreadsheet on page 72 below)
3) Select the table within the database
4) Select each field and click the left facing arrow to move the field into the Label text
area
5) Tidy the Label text area (e.g. Press enter between the address fields)
6) Select the brand and type of label for the labels to be printed on. If the correct brand
and type isn't listed use the Format tab to specify the layout
7) Click the Options tab, ensure Entire page is chosen. The Synchronize contents
check-box is so that changes made to the first label are propagated through the remaining
labels.
8) Click New Document
9) Merge as above.
5.5.8 Merge to e-mail
There is no option for merging to e-mail.

5.6 Envelopes
From the forums some people have had difficulty with envelopes. From brief
experimentation the author hasn't had any problems with OpenOffice.org 1.1.1.
5.6.1 Adding an envelope
Insert > Envelope...
5.6.2 Removing an envelope
• Place the cursor at the beginning of the envelope page
•

If the Stylist is not open, press F11 or use Format > Stylist to display it

•

Change to the Page Styles options. It's the fourth icon from the left

•

Double Click on "Default"

•

Remove the remaining elements.
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5.7 Page styles and page numbering
5.7.1 Modify a page style
In Writer all pages have a page style. To modify the page style of the page where the cursor
is positioned use Format > Page.
Warning: As the page style is being changed all pages with this style will be
changed as well.
5.7.2 Create a style
To create a new page style:
1) If the Stylist isn't currently displayed press F11 to display it
2) Click Page Styles in the Stylist (fourth icon from left)
3) Right click in the Stylist > New
5.7.3 The Page style dialog
Organizer tab
Name: Nothing tricky here simply a name to help the user remember what the settings are
for.
Next style: This setting specifies what page style to use at the next page break (manual or
automatic). Set it to a different page style when the page style is only for one page otherwise
this should be the same as Name (I.e. Keep the same page style for the following page(s).
Page tab
Paper format settings: Format is the paper size, the other settings have the same names in
Word (on the paper size tab of page setup).
Margin settings: Same as for Word each setting represent the distance from the edge of the
page.
Layout settings: Page Layout is for specifying whether the page style is mirrored, used for
left and right pages ... There are more options here than in Word, but there isn't a different
first page option – that's because that is handled by the Next style setting as mentioned above
in Organizer tab. Format refers to the format of page numbers. Register true is to make the
text line up better at the top of the page (see help for more details).
Background tab
For specifying a background color or graphic (watermark). ( An alternative to this with more
flexibility is to: create drawing object, Arrange > To Background, Anchor > To Page.
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Header / footer tabs
Headers and footers are printed between the margins of the page rather than in the top or
bottom margins. Thus the setting of height for allocating the amount of space within the main
body of the page for the header or footer. Auto height is allowing the header or footer to
grow and shrink depending on their contents.
Spacing specifies the distance between the header/footer and the main document. Dynamic
spacing is to allow the header/footer to expand into the area between the header/footer and
the main document.
The left and right margins are indenting from the margins of the page and cannot have
negative values.
The more button is for specifying borders and backgrounds for header/footer area. As it is
possible to have graphics in the background of the main document this is not the required
way of having a watermark.
Borders / columns footnote tabs
These tabs are for specifying the borders (lines around the outside), number and widths of
newspaper style columns and defining the area for footnotes (if any) for the page style.
5.7.4 Page breaks and page numbering
Changing the style used for a page and changing the numbering sequence
To insert a page break and change page style or page numbering method1:
1) Control + Enter
2) Cursor will be in the first paragraph of the new page
3) Format > Paragraph...
4) Breaks will be enabled
5) Select with Page style, specify the page style to use and specify the page number to
start from.
To insert a page break and change page style or page numbering method2:
1) Insert > Manual break...
2) By default it will specify Page breaks
3) Choose the Page style
4) Select Change page number
5) Enter the new starting page number
To insert page numbering
1) Having defined a page style with header or footer turned on.
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2) Position the cursor in the header or footer (can use mouse or key shortcut: Control +
PageUp for Header or Control + PageDown for footer).
3) Optionally type: “Page” space
4) Insert > Fields > Page Number.
5) Optionally type space “of” space “ Insert > Fields > Page Count. To insert a field
that calculates a different page count e.g. Have a title page but want to have remaining
pages say page 1 of 2 (I.e. Page Count would display 3 – not what you want): Press F2 to
display the text formula bar, type =page - 1, Enter. Unfortunately this field doesn't
automatically update but pressing F9 will update it.
Page numbers on portrait and landscape pages in the same place and orientation
1) Create a style for landscape pages. Set the margins for the landscape style such that
they correspond with the portrait style when rotated. I.e Top = left, bottom = right, left =
bottom and right = top. For page numbering on left turn on headers, on right – footers.
Select Use dynamic spacing.
2) Create a style for the landscape header or footer based on the style for the portrait
header or footer. (I.e. In the stylist select the style that is used for the portrait header or
footer > right click > New). Change the font position to 2700. If the page numbering is on
the bottom choose left alignment, for the top choose right.
3) Insert the page break and choose the page style just created (see above) don't change
the numbering.
4) In the relevant header /footer (as per step 1) insert the page number field.

5.8 Index/Tables
This section is based upon a document by Catherine Waterman, titled “How to Create and
Maintain a Table of Contents”. The full document is available for download from:
http://documentation.openoffice.org/HOW_TO/index.html.
Writer's indexes and tables feature is very similar to Words. This section uses table of
contents by way of example, but the principles apply to any of the indexes and tables. To
create indexes for tables, graphics etc, they require to have been captioned. For Alphabetical
index see 5.8.9 Alphabetical Index on page 51 below.
Like Word, Writer builds an automated table of contents from the headings in the document.
Make sure that the headings in the document are styled consistently. For example, use the
Heading 1 style for chapter titles and the Heading 2 and Heading 3 styles for chapter
subheadings.
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5.8.1 Opening Writer's table of contents feature
To open Writer's table of contents feature and insert a new table of contents in the document,
follow these steps:
1) Position the cursor in the document at the desired location for inserting the table of
contents
2) From the main menu, choose Insert > Indexes and Tables > Indexes and Tables...
The Insert Index/Table window appears
3) Click the Index/Table tab if it isn't already displayed
The Insert/Index Table window has five tabs. Four of them are used when creating a table of
contents:
•

Use the Index/Table tab to set the table's attributes

•

Use the Entries and Styles tabs to format the table entries

•

Use the Background tab to add color or a graphic to the table background

The next four sections are about how to use each of these four tabs
The preview box, located on the left-hand side of each tab, shows how the table of contents
will look. (To enable/disable the preview box, check the Preview check box in the lower
right-hand corner of the window.)
5.8.2 Using the Index/Table tab
Setting basic attributes
To set the table's basic attributes:
1) From the Type drop-down list in the Type and title area of the tab, select Table of
Contents if it isn't already selected
2) From the drop-down list in the Create index/table area, select Entire document
3) In the Create from area, check the Outline check box
4) In the Create from area, clear the Index marks check box
Adding a title
Typically the title field is left blank – so that no title is automatically created. If this field has
text then a paragraph containing the text is placed at the start of the table with style Contents
Heading.
Protecting against manual changes
To prevent users from wasting time making manual changes to the table check the
Protected against manual changes check box. If this box is checked, the table of contents
can only be updated from the Insert Table/Index window. If the box isn't checked, the table
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of contents can be changed directly on the document page, but the changes will be lost the
next time the field is updated.
Adjusting the number of levels
By default, Writer evaluates 10 levels of headings when it builds the table of contents. To
change the number of levels evaluated, enter the desired number in the Evaluate up to level
spin box.
Assigning custom styles
Writer automatically assigns to the table of contents all paragraphs formatted with the default
heading styles (Heading 1, Heading 2, and so on). To assign paragraphs formatted with
custom styles, follow these steps:
1) In the Create from area, check the Additional Styles check box
2) Click the (...) button to the right of the check box. The Assign Styles window appears
3) In the Not applied column, click the style that you want to assign to the table of
contents
4) Use the >> button to move the selected style to the desired outline level. For example,
for paragraphs formatted with the selected style to appear as top-level entries in the table
of contents, click the >> button once to move the style into the 1 column. To move the
style in the opposite direction, use the << button
5) Click OK to save the changes and return to the Index/Table tab. Or, click Cancel to
return without saving changes
5.8.3 Using the Entries tab
Use the Entries tab, to format the entries in the table of contents. For each outline level, it is
possible to add and delete elements, such as chapter numbers, and to apply character styles to
individual elements.
To begin, click a level number in the Level column to select an outline level. (You'll be able
to apply your changes to all outline levels later.) The Structure line displays the elements for
entries in that level. Each button on the Structure line represents one element:
•

The E# button represents the chapter number

•

The E button represents the entry text

•

The T button represents a tab stop

•

The # button represents the page number

•

The LS button represents the start of a hyperlink. (This button doesn't appear on the
default Structure line.

•

The LE button represents the end of a hyperlink. (This button doesn't appear on the
default Structure line.)

•

Each white field on the Structure line represents a blank space
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Deleting elements
To delete an element from the Structure line, click the button that represents that element and
then press the Delete key on the keyboard. For example, to delete a tab stop, click the T
button and then press Delete.
Adding elements
To add an element to the Structure line, follow these steps:
1) Click in the white field to the left of where the element is to be inserted
2) Click one of the five buttons that are just below the Structure line. (For example, to
add a tab stop, click the Tab stop button.) A button representing the new element appears
on the Structure line
Note that if a hyperlink is inserted both the beginning and end of the link must be specifed.
For example, to change the default Structure line so that the chapter number and the entry
text form a hyperlink, follow these steps:
1) On the Structure line, place the cursor in the white field to the left of the E# button.
(Recall that the E# button represents the chapter number.)
2) Click the Hyperlink button. An LS button, representing the start of the hyperlink,
appears on the Structure line
3) On the Structure line, place your cursor in the white field to the right of the E button.
(Recall that the E button represents the entry text.)
4) Click the Hyperlink button again. An LE button, representing the end of the
hyperlink, appears on the Structure line
Applying character styles
To apply a character style to an element on the Structure line:
1) On the Structure line, click the button that represents the desired element for applying
a style
2) From the Character Style drop-down list, select the style to apply. Writer applies the
selected style to the selected element.
To view or edit the attributes of a character style, select the style from the Character Style
drop-down list and then click the Edit button.
Applying changes to all outline levels
To apply the displayed structure and formatting to all outline levels, click the All button.
5.8.4 Using the Styles tab
Use the Styles tab to apply paragraph styles to the table of contents. It is possible to apply a
different paragraph style to each outline level of the table.
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To apply a paragraph style to an outline level, follow these steps:
1) In the Levels list box, select the desired outline level by clicking it
2) In the Paragraph Styles list box, click the paragraph style to apply
3) Click the < button to apply the selected paragraph style to the selected outline level.
To remove paragraph styling from an outline level:
1) In the Levels list box, select the desired outline level by clicking it
2) Click the Default button
To view or edit the attributes of a paragraph style, click the style in the Paragraph Styles list
box and then click the Edit button.
5.8.5 Using the Background tab
Use the Background tab to add color or a graphic to the table background.
Adding color
To add color to the background of the table of contents, simply click the desired color in the
color grid.
Adding a graphic
To add a graphic to the background of the table of contents, follow these steps:
1) From the As drop-down list, select Graphic. The Background tab displays the
graphics options
2) Click the Browse button. The Find Graphics window opens
3) Find the graphic file that you want to use and click the Open button. The Find
Graphics window closes and the selected graphic appears in the graphic preview box on
the right-hand side of the Background tab. (If you don't see the graphic, check the
Preview check box underneath the graphic preview box.)
4) In the Type area of the Background tab, choose how you want the background graphic
to appear:
•

To position the graphic in a specific location in the background, select Position and
then click the desired location in the position grid.

•

To stretch the graphic so that it fills the entire background area, select Area.

•

To repeat the graphic across the entire background area, select Tile.

Removing color or graphics
To remove color or graphics from the table background, follow these steps:
1) From the As drop-down list, select Color
2) Click No Fill on the color grid
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5.8.6 Editing a table of contents
To edit an existing table of contents, right click anywhere in the table of contents and choose
Edit Index/Table from the context menu. The Insert Index/Table window opens and you can
edit and save the table using the four tabs described in the previous section.
5.8.7 Updating a table of contents
To update a document's table of contents when changes are made to the document, right click
anywhere in the table of contents and choose Update Index/Table from the context menu.
Writer updates the table of contents to reflect the changes in the document.
5.8.8 Deleting a table of contents
To delete the table of contents from a document, right click anywhere in the table of contents
and choose Delete Index/Table from the context menu. Writer deletes the table of contents.
Note: Writer won't confirm the delete! To undo the deletion click Undo or press Control + Z
straight away.
5.8.9 Alphabetical Index
To create an alphabetical index either fields need to be inserted manually or a concordance
file created.
To insert fields manually for the index:
1) Select most important occurrence of the word or term
2) Insert > Indexes and Tables > Entry
3) For more information on keys click Help
4) Check Main Entry and (usually) check the remaining check-boxes
5) Click Insert and every occurrence of the selected word will have an index entry field
6) Repeat for other desired words and terms
7) Insert the Alphabetical Index as for Table of contents except instead of choosing
“Table of contents” choose “Alphabetical index”.
To create a concordance file:
1) Insert > Indexes and Tables > Indexes and Tables...
2) For type choose Alphabetical Index
3) Check Concordance file
4) Click the File button > New
5) Specify a name for the concordance file
6) Click Help (if required) for details on how to fill-in the dialog.
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5.9 Conditional text
In Word the only way to have conditional text is with the “if” field3 the equivalent in Writer
is the field “Conditional text”.
To insert a conditional field in Writer: Insert > Fields > Other > Functions > Conditional
text or Control + F2 > Functions >Conditional text.
There is also a field “Hidden text” that hides the text when the condition is true.
Working with the relevant fields for conditional text, both in Word and in Writer, means that
only small amounts of text can be conditional. However, there are times when having whole
paragraphs or sections of text be conditionally hidden is very convenient. Some examples:
•

A test so that the same document can be used for the test itself and for the model answers

•

Technical documents where the same document with variations can be used for similar
models of equipment

To provide this level of functionality Writer provides conditionally a hidden paragraph field
and the ability to conditionally hide sections. Here's an example to show how this could be
done:
1) Ensure that hidden text is viewable: Tools > Options > Text Document >
Formatting Aids, tick both “Hidden text” and “Hidden paragraphs”
Note: Conditionally hidden sections are not visible regardless of these settings if the
condition for hiding them is true.
2) At the top of the document: Insert > Fields > Other > Variables
3) Name: DocType. Value: Model Answers
4) At the start of a one paragraph answer Insert > Fields > Other > Functions > Hidden
Paragraph. For the condition type DocType == “Test” (To make this easier to
repeatedly insert create an autocorrect entry)
5) For longer answers: Enter the model answer, select it, Insert > Section..., tick Hide,
and enter DocType == “Test” for the condition.
6) To print the document for a test double click the field at the top of the document
created in steps 2 and 3, and change the value to Test. Print as usual.
Note 1: The field “Input list” has a name but this is not a variable so it's value cannot be
used in the condition.
Note 2: It is easiest if the selection doesn't include the last paragraph to keep adding
sections. But if the last paragraph is selected simply move to the end of the document
(Control + End) then press Alt + Enter.

3 To the best of the Author's knowledge.
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5.10 Master documents
It is the author's view that master documents in Writer are about as unreliable as they are in
Word, and so the author's recommendation is not to use them. This is contrary to a lot of
other peoples' view.
See the issue list for master documents:
http://www.openoffice.org/issues/buglist.cgi?short_desc=master+document&issue_status=N
EW&issue_status=STARTED&issue_status=REOPENED&issue_status=RESOLVED&issu
e_status=VERIFIED&issue_status=UNCONFIRMED&short_desc_type=allwords&cmdtype
=doit.
An example of why the author doesn't recommend using master documents: There is no way
of having a landscape page in a sub-document and that page remaining a landscape page in
the master. The only workaround is to have that document be part of the master document
rather than a sub-file.
Help covers using Master documents quite well or see 5.1.14 Work with large or complex
documents on page 35 above.
It is possible to insert cross-references across sub-documents but the names of the references
must be typed in rather than selected from a list. Use Insert > Fields > Other... >
References
Writer appears to be quite stable with large documents (in the author's experience more so
than Word) so inserting all the files into one file is the author's recommendation.
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6 Spreadsheet documents
6.1 Main differences
6.1.1 Separating parameters in functions
The single biggest difference between using Calc and Excel is that Calc uses semicolons to
separate parameters in a function and commas for separating non-contiguous ranges which is
the reverse of Excel.
6.1.2 Number of rows
Calc only supports 32000 rows (compared to Excel's 65,536). When importing an Excel
workbook that contains a sheet with more than 32000 rows Calc creates a new sheet so the
data isn't lost but any formulas that refer to that data need to be manually changed.
6.1.3 Form fields
Combo boxes, list boxes and check boxes with links to spreadsheet cells all import and
export properly (due to font handling the number of rows displayed in list boxes may be
slightly different). List boxes in Calc can either have multi-selection or not where as Excel
has two multi selection modes multi and extend. In Excel a multi-selection listbox's link to a
cell is ignored (at least in Excel2000 Author hasn't checked Excel XP) whereas in Calc the
link works but if more than one item selected the cells value is set to #N/A.
Option buttons import into Calc but the link with cells works differently. In Calc each option
button has it's own link to a cell setting its value to true or false depending on whether the
option is selected. In Excel the cell link returns the number of the selected option button. On
exporting option buttons to Excel the option button lose their radio operation – I.e. They are
not grouped so that selecting one “unselects” the others.
Scroll bars and spinners are not implemented in Calc.
6.1.4 Named ranges and “Natural Language” formulas
It is possible in some versions of Excel to have the same range name on different sheets, this
is not possible in Calc. Excel can have named ranges of the form name1:name2, Calc can't
handle these and imports formulas containing them with #Name.
Calc does have “Natural Language” this is where column and/or row labels are used (without
defining them as range names) in a formula. In Excel to refer to a cell a space is used
between the label names, in Calc an exclamation mark (sometimes called pling) “!” is used.
In Calc the names are enclosed in single quotes (done automatically by Calc if the label starts
with a letter and only has alphanumeric characters). To turn this feature on/off use: Tools >
Options... > Spreadsheet > Calculate >Automatically find column and row labels
6.1.5 Array Formulas
Calc supports array formulas but there are two things which Excel can do that Calc can't do.
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In Excel it is possible to have an array formula (array formulas are formulas entered using
Control+Shift+Enter) with two ranges in the formula and excel matches each cell in the
ranges to get a result. E.g. {=SUM(IF(A2:A5=1,B2:B5))} would work like sumif and sum
those cells in column B where in the same row column A contained a 1. Calc returns
“#NAME?”. Often this can be worked-around by using sumif, countif or the database
functions.
Array constants are not available in OpenOffice.org. The work-around is to have the constant
values in cells on a sheet and refer to them.
Note: OpenOffice.org help refers to array functions as matrix functions.
6.1.6 Optional parameters in formulas
Some formulas have more than one optional parameter at the end of the parameter list. In
Excel it is possible to leave an optional parameter blank and specify a later parameter, this is
not possible in Calc.
E.g. In Excel to calculate an annuity =PV(0.05,10,100,,1) returns -$810.78; in Calc =PV
(0.05;10;100;;1) returns Err:511.
The work around is to put values in for the missing parameters. E.g. For the above example
putting a zero in for the blank parameter returns the same result for the annuity.
6.1.7 Functions
Statistical, engineering and financial functions
The statistical functions return slightly different results, they are the same up to at least 5
decimal places after that there is a discrepancy. Gnumeric (another open source spreadsheet
package) returns exactly the same results as Excel (based on the author's simple tests). The
author hasn't compared the results returned by a statistical package such as R or SAS for the
statistical functions.
In Excel some of the financial functions accept string parameters for dates, in
OpenOffice.org they require a serial number, although you can simply type in the dates in
date format without quotes.
Analysis ToolPak Functions
The function EFFECT provided by the Analysis ToolPak for Excel is converted to
EFFECT_ADD and returns the same results.
Other functions not implemented / imported
Only three other functions are not imported INFO, GETPIVOTDATA, HYPERLINK.
Hyperlinks are supported but not as a function – use the Hyperlink button on the Function
bar.
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6.1.8 DataPilot / Pivot Table
DataPilots are Calc's equivalent to Excel's Pivot Tables. However there are a number of
limitations. Pivot tables import from Excel into Calc but as soon as they are worked on these
limitations become apparent. The limitations are:
•

There is no PivotChart facility but a DataPilot can be used as the data source for a chart.

•

Page fields have not been implemented but there is a filter option which gives similar
functionality

•

Can have no more than 8 fields in the data, row or column areas

•

There is no ability to group data (e.g. For a date field grouping by month can't be done).
The work around is to create a new column with a formula for calculating the grouping
(e.g. =Month())

•

Can't define different formats for different fields

•

No calculated fields

•

There is no ability to show data fields as things like “Difference From” or “% of”

•

The Application Program Interface specification is incomplete for writing macros that
work with DataPilots. E.g. The ability to control via another program, such as
OpenOffice.org's own macro language, BASIC, whether the tables have grand totals or
having access to DataPilots created from external data.

6.1.9 Autofilter
AutoFilter imports and exports ok with the required rows being hidden. However, there are a
number of differences between Excel and Calc:
•

There is only one AutoFilter active for a spreadsheet document at a time. The rows remain
hidden but the drop downs in the first row disappear on applying AutoFilter elsewhere

•

The remaining visible row numbers don't change color to warn that there is a filter in
place

•

Error values don't show as an option in the drop down lists when cells in the column have
errors

•

In the drop down lists the equivalent to Excel's “Custom” is called “Standard”

•

The top 10 in the drop down list is literal, but to get the same degree of control, use
Standard and specify “largest”, “largest%”, “smallest” or “smallest%” in the condition
field

•

Use regular expressions for specifying criteria to select rows based upon the text in the
cells. To do this: Choose “Standard” from the drop-down list, click More so that the rest
of the dialog is displayed, check regular expressions. Table 13 below has some examples
to help an Excel user to use regular expressions. See also 2.13.4 Regular Expressions on
page 14 above for some more examples.
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Table 13: Example regular expressions for AutoFilter

Excel custom command

Comparison Field

Equivalent Regular
Expression

Begins with x

=

^x.*

Does not begin with x

<>

^x.*

Ends with x

=

.*x$

Does not end with x

<>

.*x$

Contains x

=

.*x.*

Does not contain x

<>

.*x.*

The user is not limited to these regular expressions, they are included here to show how to
achieve the same result for AutoFilter in Calc as can be achieved in Excel.
6.1.10 Text to columns
There is not an option to do this in Calc.
6.1.11 Solver
There is no equivalent in Calc to the Solver add-in for Excel.
6.1.12 Charts
Chart types that Excel provides that Calc doesn't:
•

Bar of pie converts to a 2D - columns - normal

•

Pie of pie converts to a 2D - columns - normal

•

Radar filled converts to 3D – columns deep

•

Radar with markers – converts to 2D – net – normal but counter clockwise rather than
Excel's clockwise

Other charting issues include:
•

Charts are slower to update in Calc than in Excel

•

Fewer axis options such as no option for having an inverted y axis (negative at top
towards positive at bottom)

•

The data must be contiguous with the labels in the first row or column

•

To change the range click on the border of the chart, so that it is selected (green selection
points) > Right Click > Modify Data Range...

6.1.13 Number formats
There is no “accounting” format (with the currency symbol at the left edge of the cell). A
work-around would be to have another column to the left that contains the currency symbol.
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There is no predefined option for bracketing negative numbers. Use a custom format such as
“$#,##0.00_);[RED]($#,##0.00)”

6.2 Interface differences between Excel /Calc
6.2.1 Keyboard shortcuts
Table 14: Excel v Calc default key shortcuts (incomplete)

Function

Excel Shortcut

Calc Shortcut

Rearranges the relative or absolute
references (for example, A1, $A$1,
$A1, A$1) in the input field.

F4

Shift + F4

Edit cell comment

Shift + F2

Control + F1

Fill right

Control + R

No equivalent

Go to specific cell

F5

F5 (shows navigator)

Insert Function

No standard equivalent

Control + F2

Enter into all currently selected cells

Control + Enter

Alt + Enter
Alt + Shift + Enter (also
applies the cell format)

6.2.2 Mouse use
To select non-contiguous blocks of cells the first selection must be two or more cells then
proceed as in Excel holding down Control to select the next block(s) or
•

Click once on the field "STD" (STanDard) in the status bar

•

The field now shows "EXT" (EXTended selection)

•

Another click and it changes to "ADD" (ADD to selection)

Note: the ADD mode is the equivalent to Control + click and EXT is equivalent to Shift +
click.
Double clicking the bottom right corner of the selection doesn't copy to the bottom of the
current region.
6.2.3 Hidden rows
There is no select only visible rows command. Selecting a block of cells with hidden rows
and deleting will delete the hidden rows as well. Work-around: select each visible row
manually before deleting.
6.2.4 Navigator
The navigator's main use would be for spreadsheet documents that have a lot of sheets. Right
clicking on sheet selection controls doesn't display a dialog for selecting a sheet – so using
the navigator is faster than scrolling through the sheets.
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6.2.5 Stylist
Has two types of styles cell and page. Right click in the stylist to create, modify or delete
styles.
6.2.6 Sheet area combo-box
The sheet area combo box (left side of the Formula bar) shows the current range and can be
used to jump to a named range, but can't be used to define a range (to define a range use:
Insert > Names > Define or Control + F3).
6.2.7 Function List
The Function list is a floating / dockable window that provides information about the
available functions. It is an alternative to AutoPilot:Functions. To view it: Insert > Function
List.
6.2.8 Error values
Some functions in Calc return esoteric error messages like: Err:503. To get a message that is
more meaningful select the cell with the error message then look at the right end of the status
bar in this case Error: Invalid floating point operation (E.g. Division by zero).

6.3 Import/Export issues
6.3.1 Password protected Workbooks
Workbooks that have been password protected in Excel cannot be opened by Calc. The file
needs to be saved in Excel without password protection so that Calc can open it.
6.3.2 Other issues
Other issues are covered in 6.1 Main differences on page 54 above above.

6.4 Conditional formatting and styles
Conditional formating requires styles to be defined – use the stylist to do so.

6.5 Working across spreadsheets, web pages and
database data
6.5.1 Working across spreadsheets
Contrary to help and other references using the navigator with a “Drag Mode” of Link,
doesn't work for accessing the contents of one spreadsheet in another.
To refer to the contents of cells in another spreadsheet document or Workbook the syntax is
'url of other workbook'#$sheetname!cellrange. E.g. On a Linux system
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'file:///home/hillview/Documents/Tests/Address.xls'#$Sheet1.A1
or on a Windows system:
'file:///C:/Documents/Tests/Address.xls'#$Sheet1.A1

To input these links it is possible to:
1) Type in the formula up to the point where the link is required
2) Window > [select desired document]
3) It isn't obvious that this is working but it is, select the desired cell or range of cells
4) Window > [select the original document]
5) Finish entering the formula
6) What is disconcerting is that the value displayed is based on the value of the cell (or
range of cells) when the linked document was last saved.
7) So to check it: save the linked document and update the link in the document (Edit >
Links) that contains the link
Note: To reiterate - these links do not update automatically! To get them to update use: Edit
> Links > [select the desired link] > Update. The update works from the saved file – so if
both files are open and the file that the link is based on is updated that file must be saved
before updating the link.
To have dynamic updating of data between two spreadsheets use:
1) Select and copy the range of cells to be linked to
2) Change to the spreadsheet that requires the link
3) Edit > Paste Special > Link (check-box down the bottom left)
These cells will have dynamic access to the contents of the other sheet and the values
returned can then be used in other formulas.
6.5.2 Links to html data or other spreadsheets
To link to data on the net:
1) In a browser navigate to the desired page
2) Copy the URL
3) In Calc
4) Insert > External Data...
5) Paste in the URL
6) This step is not obvious: press Enter wait a moment and the bottom list box (called
Available tables / ranges) will show:
•

HTML_all (the entire page)
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•

HTML_tables (all the tables on the page_

•

HTML_1 (each table consecutively numbered on the page)

7) Select the desired option from the list box
8) Optionally check the Update every check box and specify how often to update
The same process can be used for linking to data in spreadsheets.
Note: The source file must be saved before the update can take place. (In OpenOffice.org
AutoSaves over write the original file, so with AutoSaves turned on this feature could be
more useful than it at first appears. The author hasn't experimented with this feature to test
its limits).
6.5.3 Links to database data
1) Display the Data source viewer (F4)
2) In the Data Explorer window Navigate to the desired table or query (if it isn't visible
click Explorer on / off - left button in data source toolbar)
3) Drag the table or query onto the sheet (see 12 Data-sources on page 70 below for
information about working with data sources such as registering the data source)

6.6 Printing
Calc and Excel have the same printing functionality just the location of where to get to the
settings is slightly different.
Unlike Excel, a print range must be specified first.
To define the print range (this is the equivalent of in Excel File > Page Setup > Sheet, first 3
fields):
1) Format > Print Ranges > Edit...
2) Select the desired range for each of the fields
3) Note it is possible to select noncontiguous areas for the print area with each area being
on a separate page. Each area is separated by a semicolon.
Like Excel, Calc provides a Page break view. The menu option is a toggle:
•

View > Page break preview

The other settings such as whether to have grid-lines is done via the page style:
•

Format > Page... > Sheet

Print Options for suppressing blank pages and printing only the selected sheet(s) can be set:
•

Tools > Options... > Spreadsheet > Print

Note: Recommend having both these options set.
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To Print:
1) File > Print
2) Optionally click Options to change the settings for suppressing blank pages and /or
only the selected sheet(s)
3) Other settings are the same as in Excel
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7 Presentation documents
7.1 Good practice in presentations
Rule of seven:
•

No more than seven points per slide

•

No more than seven words per point

KISS – Keep it simple – too many effects detract from your message rather than enhance it.
•

Minimum font size of 18pt preferably 20pt

7.2 Main differences between PowerPoint and Impress
7.2.1 Accessing different views
In PowerPoint the buttons for quickly changing the view are down the bottom left. The
equivalent buttons are top right side just above the vertical scroll bar in Impress. The buttons
down the bottom left are to toggle between slide view and master view (don't need to
remember to hold down shift when clicking the slide view button) and a button for accessing
objects in the background.
Impress provides a handout view for fine tuning how the hand out will look, rather than just a
print option.
7.2.2 Multimedia
There appears to be no settings for multimedia custom animations. E.g. the ability to play a
sound for the next x slides.
Sound
Going Insert > Object > Sound... crashed OpenOffice.org.
Dragging and dropping a sound file from the Gallery places a control Button on the slide,
which plays on being clicked when running the slide show.
7.2.3 Chart animations
There is no facility in Impress for “Chart Effects” as there is in PowerPoint, such as
presenting a series or category at a time. On import the charts simply appear. A work around
is to have multiple copies of the chart with each one setup to display as desired.
7.2.4 Pack and Go
This feature in PowerPoint allowed a PowerPoint file to be split up over several floppy disks
and assured that all related files were included. This facility is not included in Impress, nor
can Impress open such files.
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7.2.5 Fields
Date fields are exported as text so don't automatically update.
Fields are shown with gray background when editing so that they are recognizable as fields.
7.2.6 Action Settings / Interaction
PowerPoint provides action settings for mouse over, Impress doesn't have this option, only
on mouse click, so that is what they get mapped to. PowerPoint has an option for
highlighting the object on mouse click / mouse over, Impress doesn't have this so it gets
ignored on import.
7.2.7 Object effects / animations and slide Transitions
For the equivalent object effects / animations between PowerPoint and Impress see
For the equivalent slide transitions between PowerPoint and Impress see
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10 FontWorks (WordArt equivalent)
Instead of Microsoft Office's WordArt, OpenOffice.org has FontWorks. The FontWorks
window is dockable at the sides of the screen. See 2.7 Side panes - Docked / Floating
Windows on page 5 above.
To use FontWorks:
1) Select the Text Tool (found on the Draw tear off toolbar in Writer and Calc and on the
Main toolbar in Draw and Impress) it looks like a large T.
2) Draw a text frame in the document
3) Type some text (if text isn't typed into the frame before clicking outside the text frame
the text frame is removed)
4) Format > FontWork
5) Apply the desired effects from the fontwork toolbox
Note: A popular feature of WordArt that FontWork doesn't is gradient colour fills of the text.
A work-around is to use Draw instead where it is possible to convert text to curves, apply a
gradient fill and then copy this object into your document.
To change the color of the FontWork text:
1) Double click the FontWork object
2) Select the text
3) Format > Character.. > Font Color
Note: The colour controls in the object toolbar do not relate to the FontWork text but rather
to the contour line that the text is following.
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11 Math formula editor / Equation Editor
The equivalent to Microsoft Office's Equation Editor in OpenOffice.org is Math formula
editor. By default the Command window of Math formula editor is docked at the bottom, it
can also be floating or docked at the top. See 2.7 Side panes - Docked / Floating Windows on
page 5 above.
This is just a quick guide based on the authors experience, for a more detailed how to see:
http://www.openoffice.org/issues/show_bug.cgi?id=15403.

11.1 To insert an equation:
1) Display the Insert Object toolbar by clicking the Insert Object on the Main toolbar.
2) Click Insert OpenOffice.org Math object

11.2 Customizing the interface
•

To show/hide the Selection toolbar: View > Selection

•

To turn on/off automatic screen updating View >AutoUpdate display. When AutoUpdate
display turned off - to check what the formula looks like use F9 or View > Update.
Recommend turning off AutoUpdate display

11.3 Entering a formula
There are two main ways of entering a formula, by typing in the commands in the command
Window (to get assistance right click for a context menu), or by clicking in the Selection
toolbox.
All the commands are listed at the end of this section.
∑ X U
2= ∑ X
is:
Where: ...
i

E.g. The command for:

i

i

hat %beta_2 = {sum {X_i + U_i}}
over
{sum X_i}
newline
“Where: ...”

•

To change the amount of space between elements use: Format > Spacings...

•

Commands can simply be typed in

•

Commands read left to right and either effect the next object (unary operators e.g. “_”) or
objects either side (binary operators e.g. “over” , to get the command to effect more than
one object enclose it in braces

•

White space is ignored (unless enclosed in quotes) so use it to make your commands
readable the command above is easier to read than:
hat%beta_2={sum {X_i+U_i}}over{sum X_i}newline“Where: ...”

yet they do exactly the same thing
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•

To learn the different commands either use the Selection toolbox for a visual
representation or the context menu for a written representation. Some examples from the
above follow:

•

Hat is the command to put a caret over the next character. Hat is found under Attributes

•

Beta is obtained from the symbol catalog: Tools > Catalog... or Symbols button on the
Main toolbar (the “%” says interpret what follows as the name of a symbol)

•

The underscore character is for subscripts, in this case only the next character is
subscripted so no braces are required. Subscripts are found under Formats

•

The = sign obtainable from Relations

•

“over” is obtainable from Formats

•

Need to brace the numerator (top of fraction) and the denominator (bottom of fraction) as
they contain more than one thing

•

“sum” is obtainable from operators

•

Literal text is enclosed in quotes

11.4 Working with Math within Writer
To keep the formula smaller so that it looks better in-line with other text when in Math use:
Format > Text mode
To convert text that is typed into writer to an equation:
1) Select the text
2) Click Insert OpenOffice.org Math Object on the Insert Object toolbar
To number equations:
1) at the start of a line type: fn
2) Press F3, this will insert a predefined autotext consisting of a two cell table, with a
formula in the first cell and a numbering field in the second. The line below has the
autotext entry but with borders added to the table so it is easier to see how it is working.
E=mc 2

(1)

The numbering is done using the field type “Number range” and the variable Text. So to
have more control over numbering equations a user could create their own styles and or
autotext entry and use a Number Range field for the numbering.

11.5 Symbols and commands
See Appendix I Math formula – symbols and commands on page 106.
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12 Data-sources
OpenOffice.org doesn't have a database server capability (limited ability to create and work
with dBase format files), but it does have a great integrated4 client ability. To replace Access
entirely requires transferring .mdb (Access' own proprietary format) files to another database
server such as MySQL. For information on how to do this see:
http://mdbtools.sourceforge.net/.
To keep database files in .mdb format use ODBC to connect to the files: see
http://www.openoffice.org/FAQs/mostfaqs.html#10.

12.1 Working with a data-source (dBase example)
This section is based upon a “howto” written by Scott Carr, titled “How to Create a data
Source from Scratch”. The original is at:
http://documentation.openoffice.org/HOW_TO/data_source/data1_EN.html.
Other useful links:
Registering other data sources: http://openoffice.homelinux.org/index.php?s=38
Step by step guide: http://homepage.ntlworld.com/garryknight/linux/oodbase.html
Comparison with Access:
http://articles.linmagau.org/modules.php?op=modload&name=Sections&file=index&req=vie
warticle&artid=230&page=1
These steps will run you through setting up a Data Source in the OpenOffice.org system. A
dBase type database will be created as these can be created and worked on without a separate
database engine. However registered data sources of type dBase do not have the ability to
have more than one table in a query (or SQL statement) so the tables can not be related to
each other.
12.1.1 Registering the data source
1) Tools > Data Source
2) Click New Data Source
3) Enter a name for your Data Source. NOTE: In this example “TEST” is used as the
Data Source name
4) Select dBase as the Data Source. NOTE: We are using dBase, because it allows full
control over the database on a local system
5) Enter a directory for the program to store the data files in. If the directory does not yet
exist OpenOffice.org will automatically create it (checking with user first).
6) Click Apply

4 The term integrated here is used to reflect that it isn't a separate application but works-in with all the
applications in OpenOffice.org.
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12.1.2 Adding Tables in a data source
This section assumes that your Data Source allows full access to the database. Currently,
dBase is the only type that allows this type of access to files on your computer. JDBC and
ODBC can be used if you already have a Database System setup like MySQL, SQL Server,
or ORACLE.
1) Click on the Tables tab
2) Click on the New Table Design button to display the Table Design screen
3) Enter field names. E.g. Name (down arrow), Telephone (down arrow) …
4) Save the table: File > Save > [name the file]. This example will be TestTable
5) Close the Table Design screen and the Data Source dialog.
12.1.3 Viewing a data source
Data is viewed / edited using the Data source viewer sometimes referred to as the beamer or
database beamer.
1) Display the Data-source viewer by pressing F4 or Click the Data Sources button in
the Main toolbar or View > Data Sources.
2) In the data explorer, left side of Data-source viewer (if not visible click the Explorer
on/off button – the button on the left) navigate to the desired table.
E.g. Test > Tables > TableTest
12.1.4 Editing the data
This section demonstrates how OpenOffice.org can be used to enter, edit, and remove values
in a Data Source.
Note: OpenOffice.org can not edit data source files of types text or spreadsheet in the Data
source viewer.
•

To add a new record simply type into the bottom blank row of the displayed table or click
the button that looks like an asterisk “*” in the record number status bar.

•

To move between fields use Tab and Shift + Tab (this is just like any other table so key
controls and mouse clicks work as expected)

•

Editing records is simply making the change – moving to a different record saves the
change. To abort a change simply press Escape.

•

Deleting Records: Select the record(s) by clicking to the records left, selected records are
highlighted, (Control and shift keys work as expected) either press Del key or Right Click
> Delete Rows. Confirm the deletion.
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12.1.5 Using queries to select records
This is a large subject area so what follows is just a getting started guide on creating a query,
once the query is created use the query as your data-source. Help covers this in more detail,
select the index tab and type queries.
1) In the explorer window (left window showing tree like controls) of the Data source
viewer open the desired data-source (click on the “+” to the left) if required
2) Right click Queries > New Query (Design View)
3) Choose the table for your query and click Add
4) Typically the next step is double click the * to add all the field names to the query
5) Double click the field name(s) that have the data to limit the query to. E.g. The field
name might be “Keyword” and only records containing “Friend” are desired
6) Un-check the visible check-box for these criteria fields (not necessary but saves
getting the field repeated in the final table)
7) Type in the criteria in the Criterion row. E.g. 'friend' or if there might be other text in
the field for the record but it must contain the word 'friend' somewhere in the field type
LIKE '*friend*'.
8) Check the query by clicking the Run query button . To adjust the various panes
click and drag pane borders to get a desired arrangement.
9) File > Save As and name the query
10) File > Close Window

12.2 Creating a data-source from a spreadsheet
To do a Mail Merge in OpenOffice.org from a spreadsheet the spreadsheet needs to
registered as a database source, so that you'll be able to display it inside the Data-source
viewer.
1) Make sure your spreadsheet is saved (preferably in .sxc format). The top row will be
used for field names.
2) Tools > Data sources... > New Data Source
3) Give it a meaningful name
4) For Connection choose Spreadsheet
5) Click … > navigate to the desired spreadsheet
6) In the Tables tab, verify that your spreadsheet name has been selected
7) Click on OK and your sheet will be usable for things like Mail Merge
Note: This method can be used to register into OpenOffice.org whatever supported data
source type you already have present on your system.
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12.3 Database Forms
This section is based upon a document by Daniel Strome, titled “How to Link Tables Using
Named Parameters”. The full document is available for download from:
http://documentation.openoffice.org/HOW_TO/index.html. (There is a section in the
document about running a macro – this is no longer necessary.)
This section is only a very brief look as OpenOffice.org provides a full graphical user
interface as a database client.
12.3.1 Form creation using auto pilot
It is possible to create forms from scratch using the forms toolbar but to get an idea of what is
possible, using the autopilot is a good place to start.
1) File > AutoPilot > Form...
2) Follow the steps in the dialog, in the second page of the autopilot as selections are
made they are immediately visible in the newly created Writer document.
12.3.2 Form use
When using a form a Navigation toolbar should be visible (by default across the bottom of
the window). If it is not visible right click any toolbar and select Navigation bar. The
controls on this form are similar to those used in Access.
Note1: Doing a find is slow because it is handled by OpenOffice.org rather than the
database server (lot of information passing) use filters instead.
Note2: If the table is read only then it could be because:
OpenOffice.org requires a primary key (or bookmark facility) for the table, or
OpenOffice.org hasn't implemented writing to text or spreadsheet files, or
the database driver isn't providing the required privileges – try updating the database
driver (it maybe that you don't have sufficient privileges).
12.3.3 Editing the form
To edit the form display the Form functions toolbar by clicking Show Form Functions on
the Main toolbar. To toggle the form so that it can be edited click Design Mode On / Off.
Viewing / editing a controls / forms properties
1) Click the Select tool then click a control
2) Click Control Properties... on the Form functions toolbar
3) Fields are frequently grouped with labels when this is the case the title bar of the
properties window will say “Properties: Multiselection”. To ungroup the fields: Right
click > Group > Ungroup. Now select a field and see the properties
4) To change to the form's properties click Form properties on the Form functions
toolbar
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Editing controls
•

To add a control: Click a button and drag in the document

•

Many controls have an associated autopilot, to turn these off / on click the AutoPilots
On / Off button

•

To change a control from one type to another: Right click the control > Replace with >
[choose the new control type]

•

To change the order that the fields are accessed when entering data and pressing Tab:
Click Activation order

Adding a sub-form
A sub-form is where the records displayed in the sub-form is dependent on the record
displayed in the main form. The two tables must have a common field. E.g. The main form
might be customers details the sub-form the orders for that customer, and the fields in
common might be a customer identity. To add a sub-form:
1) Display the Form navigator: Click Form Navigator on the Form Functions toolbar
2) The Form navigator displays a tree of forms and their controls. Click on the form
(second level - maybe called “Standard”)
3) Right click on the form > New > Form
Note: It is very important that it is a sub form in the hierarchy otherwise this will not
work.
4) Optionally rename the sub-form
5) With the sub-form selected in the Form navigator
6) Click Table Control
7) Drag a box in the document
8) If AutoPilots is turned on select the data source again, but this time select the new
table and then its fields. If AutoPilots is turned off – specify the data source for the form
in the forms properties window, then add columns by right clicking in the top row of the
control > Insert Column > Textbox. Change the properties of the column by right
clicking it > Column...
9) Display the data properties for the sub-form: With the table control selected > click
Form Properties > Data
10) Change the content type to SQL Command
11) Enter into content something like:
SELECT * FROM Orders WHERE CustId = :x
12) Where Orders = the name of the second table, CustId is the name of the field within
that table that has the values in common with the table for the main form, x is any
variable name
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13) Scroll to the bottom of the list
14) In Link master fields type: CustomerId
Where CustomerId is the name of the field in the table of the main form
15) In Link slave field type: x
Where x is the variable used in step 11. Do not type a colon this time!
16) Click Design Mode On/ Off and it should be working

12.4 Reports
12.4.1 Report creation
1) File > AutoPilot > Report...
2) Follow the AutoPilot
3) In the last step (Save Report) choose “Modify report template”
4) Adjust the column widths (this is a table – so can drag columns or use Format >
Table... > Columns)
5) Save and close the file
6) Display the Data source viewer
7) Navigate to the data source and open Links
8) Double click on the report – a new document based on the template will be created
Note: The report must be closed or nothing will happen.
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13 Converting VBA macros to OpenOffice.org macros
As stated earlier, there is no automatic way of converting or even running VBA macros in
OpenOffice.org. This section is to give guidance on how to do this manually.
The basic control structures in VBA and OpenOffice.org are virtually identical, however the
underlying models have different concepts.
The object model for Microsoft Office is strictly hierarchical, whereas OpenOffice.org is not.
OpenOffice.org has a concept of services this means that two different objects requiring
things in common would provide the same service. For an end user this is great –
consistency. For macro programmers it adds another level of complexity.
Other resources include:
Sun Basic Programmer's Guide: http://docs.sun.com/db/doc/817-1826?q=StarOffice
Code snippets forum: http://www.oooforum.org/forum/viewforum.php?f=11
Macros and API forum: http://www.oooforum.org/forum/viewforum.php?f=9
Andrew Pitonyak's OpenOffice Macro Information: http://www.pitonyak.org/oo.php
StarOffice Programmer s Tutorial: http://api.openoffice.org/basic/man/tutorial/tutorial.pdf

13.1 The Application Program Interface (API)
documentation
13.1.1 How to get the API

13.1.2 How to read it

13.2 Differences in the integrated development
environment (IDE)

13.3 Specific how tos
VBA

OpenOffice.org BASIC
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Appendix A General Key Shortcuts
General Shortcut keys
Enter
key

Activates the focused button in a dialog

Esc

Terminates the action or dialog. If in OpenOffice.org Help: goes up one level. The
cursor is positioned in the URL on the Function Bar: returns the cursor to the
document. If the URL has been selected, you have to press the key twice.

Spacebar

Toggles the focused check box in a dialog

Arrow keys

Changes the active control field in an option section of a dialog

Tab

Advances focus to the next section or element in a dialog.

Shift + Tab

Moves the focus to the previous section or element in a dialog

Alt + Down
Arrow

Opens the list of the control field currently selected in a dialog. These shortcut
keys apply not only to combo boxes but also to icon buttons with pop-up menus.
Close an opened list by pressing the Escape key.

Del

Deletes the selected item(s) into the recycle bin.

Shift + Del

Deletes the selected item(s) without putting them in the recycle bin.

Backspace

When a folder is shown: goes up one level (goes back)

Control +
Tab

Switches to the next open document (except when positioned at the start of a
header, instead a tab is inserted)

Shift +
Control +
Tab

Moves to the previous document that is open.

Enter (if an
OLE object
is selected)

Activates the selected OLE object.

Enter (if a
drawing
object or text
object is
selected)

Activates text input mode

Control + O

Opens a document

Control + S

Saves the current document

Control + N

Creates a new document

Shift +
Control + N

Opens Templates and Documents dialog

Control + P

Prints document
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Enter
key

Activates the focused button in a dialog

Crtl + Q

Exits application

Control + X

Cuts out the selected elements

Control + C

Copies the selected items

Control + V

Pastes from the clipboard

Control + A

Selects all

Control + Z

Undoes last action

Control + Y

Redoes last action

Control + F

Calls the Find & Replace dialog.

Control +
Shift + F

Searches for the last entered search term.

Control +
Shift + J

Toggles the view between fullscreen mode and normal mode

Control +
Shift + R

Redraws the document view.

Shift +
Control + I

Enable or disable the selection cursor in read-only text or in the Help viewer.

Control + I

The Italic attribute is applied to the selected area. If the cursor is positioned in a
word, this word is also marked in italic.

Control + B

The Bold attribute is applied to the selected area. If the cursor is positioned in a
word, this word is also put in bold.

Control + U

The Underlined attribute is applied to the selected area. If the cursor is positioned
in a word, this word is also underlined.

Control +
Shift + O

Sets the cursor on the Load URL field on the Function Bar.

Alt + O

In the Spelling dialog, the word that was originally marked as unknown/incorrect
(original) will be transferred to the input box (word).

Using the Function Keys
Shortcut keys

Effect

F1

Starts the OpenOffice.org Help
In the OpenOffice.org Help: jumps to main help
page.

Shift + F1

Context Help

Shift + F2

Turns on Extended Tips for the currently
selected command, icon or control.
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Shortcut keys

Effect

Control + F4 or Alt + F4

Closes the current document (close
OpenOffice.org when the last open document is
closed)

F6

Sets focus in next subwindow (for example,
document/data source view)

Shift + F6

Sets focus in previous subwindow

F10

Activates the first menu (File menu)

Shift + F10

Opens the context menu

Control + F11

Opens the Style Catalog

Shortcut keys in the Gallery
Shortcut keys

Result

Tab

Moves between areas

Shift + Tab

Moves between areas (backwards)

Shortcut keys in the New Theme area of the Gallery:
Shortcut Keys

Effect

Up arrow

Moves the selection up one

Down arrow

Moves the selection down

Control + Enter

Opens the Properties dialog

Shift + F10

Opens a context menu

Control + U

Refreshes the selected theme

Control + R

Opens the Enter Title dialog

Control + D

Deletes the selected theme

Insert

Inserts a new theme

Shortcut keys in the Gallery preview area:
Shortcut Keys

Effect

Home

Jumps to the first entry

End

Jumps to the last entry
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Shortcut Keys

Effect

Left Arrow

Selects the next Gallery element on the left

Right Arrow

Selects the next Gallery element on the right

Up Arrow

Selects the next Gallery element above

Down Arrow

Selects the next Gallery element below

Page Up

Scroll up one screen

Page Down

Scroll down one screen

Control + Shift + Insert

Inserts the selected object as a linked object into the current document.

Control + I

Inserts a copy of the selected object into the current document.

Control + T

Opens the Enter Title dialog

Control + P

Switches between themes view and object view

Spacebar

Switches between themes view and object view

Enter

Switches between themes view and object view

Step backward (only in
object view)

Switches back to main overview

Navigating through OpenOffice.org without a mouse
Shortcut Keys

Effect

F6

Moves the cursor from top to bottom and from right to left
through every part of the OpenOffice.org window.

Shift + F6

Moves the cursor in the opposite direction through every part
of the OpenOffice.org window.

Control + F6

Places the cursor in the document

Control + Tab

Moves the cursor from top to bottom and from right to left
through every part of the OpenOffice.org window.

Shift + Control + Tab

Moves the cursor in the opposite direction through every part
of the OpenOffice.org window.

Left/Right Arrows

Moves left/right to the next element in a horizontal bar

Up/Down Arrow

Moves up/down to the next element in a vertical bar

Home

Moves to the first entry

End

Moves to the last entry

Enter

Press the Enter key to execute the command associated with
the icon.

Esc

Closes a menu or floating toolbar.
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Editing Shortcut Keys in the Customize Toolbars
dialog
Shortcut Keys

Effect

+ key

Opens the list of Available Buttons for a button category.

- key

Closes the list of Available Buttons for a button category.

Spacebar

Toggles button visibility in Buttons in use list box.

Insrt

Adds the icon selected in the left list box to the right list box.

Del

Removes the selected icon from the Buttons in use list box.

Selecting Rows and Columns in a Table
Shortcut Keys

Effect

Spacebar

Toggles row selection, except when the row is in edit mode.

Control + Spacebar

Toggles row selection

Shift + Spacebar

Selects the current column

Shortcut Keys for Drawing Objects
Shortcut Keys

Effect

Select the toolbar with F6. Use
the Down Arrow and Right
Arrow to select the desired
toolbar icon and press Control +
Enter.

Inserts a Drawing Object

Select the document with
Control + F6 and press Tab

Selects a Drawing Object

Tab

Selects the next Drawing Object

Shift + Tab

Chooses the previous Drawing Object

Control + Home

Selects the first Drawing Object

Control + End

Selects the last Drawing Object

Esc

Ends Drawing Object selection

Esc (in Handle Selection Mode)

Exit Handle Selection Mode and return to Object Selection
Mode.

Up arrow

Moves the selected Drawing Object up
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Shortcut Keys

Effect

Down Arrow

Moves the selected Drawing Object down

Left Arrow

Moves the selected Drawing Object left

Right Arrow

Moves the selected Drawing Object right

Alt + Up/Down/Left/Right
Arrow

Moves the selected Drawing Object one pixel (in Selection
Mode)
Re-sizes a Drawing Object (in Handle Selection Mode)
Rotates a Drawing Object (in Rotation Mode)
Opens the properties dialog for a Drawing Object
Activates the Point Selection mode for the selected drawing
object

Spacebar

Select a point of a drawing object (in Point Selection mode) /
Cancel selection. The selected point blinks once per second.

Shift + Spacebar

Select an additional point in Point Selection mode

Control + Tab

Select the next point of the drawing object (Point Selection
mode)
In Rotation mode, the center of rotation can also be selected.

Shift + Control + Tab

Select the previous point of the drawing object (Point Selection
mode)

Control + Enter

A new drawing object with default size is placed in the center
of the current view.

Control + Enter at the Selection
icon

Activates the first drawing object in the document.

Esc

Leave the Point Selection mode. The drawing object is selected
afterwards.
Edit a point of a drawing object (Point Edit mode)

Up/down/left/right arrow

Move the selected point (the snap-to-grid functions are
temporarily disabled, but end points still snap to each other).

Any text or numerical key

If a drawing object is selected, switches to edit mode and places
the cursor at the end of the text in the drawing object. A
printable character is inserted.

Window Shortcut Keys
Shortcut Keys
F4 + modifier key

Effect
Docks and undocks current window.
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Query design - In the query design
Shortcut Keys

Results

F6

Jump between the query design areas.

Delete

Deletes a table from the query design.

Tab

Selects the connection line

Shift + F10

Opens the context menu

F4

The data source view is shown/hidden by pressing the (F4) key with a
text, spreadsheet or form document open.

Control Properties
Shortcut Keys

Results

Alt + Down Arrow

Opens the combo box.

Alt + Up Arrow

Closes the combo box.

Shift + Enter

Inserts a new line.

Up arrow

Positions the cursor in the previous line.

Down arrow

Puts the cursor into the next line.

Enter

Completes the input in the field and places the cursor into the next
field.

Control + F6

Sets the focus (if not in design mode) to the first control. The first
control is the first one listed in the Form Navigator.

Shortcuts for creating Basic dialogs.
Shortcut Keys

Results

Control + PageUp

Jumps between tabs.

Control + PageDown

Jumps between tabs.

F6

Jump between windows.

Tab

Selection of the control fields.

Shift + Tab

Selection of the control fields in opposite direction.

Control + Enter

Inserts the selected control.

Arrow keys

Moves the selected control in steps of 1 mm in the respective
direction. In point edit mode, it changes the size of the selected
control.
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Shortcut Keys

Results

Alt + arrow keys

Moves the selected control in the respective direction of one pixel.

Control + Tab

In point edit mode, jumps to next handle.

Shift + Control + Tab

In point edit mode, jumps to previous handle.

Esc

Leaves the current selection.

Control + arrow keys

Moves in the respective direction.
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Appendix B Writer key shortcuts
Writer navigation keys
Key

Function

+ Control key

Right/left arrow keys

Moves the cursor one character
to the left or to the right.

Moves the cursor one word to the
left or to the right.

Up/down arrow keys

Moves the cursor up or down one (Control + Alt) Moves the
line.
current paragraph up or down.

Home

Moves the cursor to the
beginning of the current line.

Moves the cursor to the
beginning of the document.

Home in a table

Moves the cursor to the
beginning of the contents in the
current cell.

Moves the cursor to the
beginning of the contents of the
current cell. Press again to move
the cursor to the first cell in the
table. Press again to move the
cursor to the beginning of the
document.

End

Moves the cursor to the end of
the current line.

Moves the cursor to the end of
the document

End n a table

Moves to the end of the contents
in the current cell.

Moves the cursor to the end of
the contents of the current cell.
Press again to move the cursor to
the last cell in the table. Press
again to move the cursor to the
end of the document.

PgUp

Scrolls up one page.

Moves the cursor to the header.

PgDn

Scroll down one page.

Moves the cursor to the footer.

General Writer
Shortcut Keys

Effect

F2

Formula Bar

Control + F2

Insert Fields

F3

Complete AutoText

Control + F3

Edit AutoText

F4

Open Data Source View

F5

Navigator on/off
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Shortcut Keys

Effect

Shift + F5

Select next frame

Control + Shift + F5

Navigator on

F7

Spellcheck

Control + F7

Thesaurus

F8

Extension mode

Control + F8

Field shadings on / off

Shift + F8

Additional Selection

F9

Update fields

Control + F9

Show fields

Shift + F9

Calculate Table

Control + Shift + F9

Update Input Fields

Control + F10

Nonprinting Characters on/off

F11

Stylist on/off

Shift + F11

Create Style

Control + Shift + F11

Update Style

F12

Numbering on

Control + F12

Insert or edit Table

Shift + F12

Bullets on

Control + Shift + F12

Numbering / Bullets off

Control + A

Select All

Control + J

Justify

Control + D

Double Underline

Control + E

Centered

Control + F

Find and Replace

Control + Shift + P

Superscript

Control + L

Align Left

Control + R

Align Right

Control + Shift + B

Subscript

Control + Y

Redo last action

Control + 1

Single Line Spacing

Control + 2

Double Line Spacing

Control + 5

1.5 Line Spacing
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Shortcut Keys

Effect

Control + Plus Key( + )

Calculates the selected text (for example, if 3487 + 3456 is selected, it
calculates the result). The result is copied to the clipboard and can be
pasted into the document.

Control + Hyphen(-)

Custom hyphens; hyphenation set by you.

Control + Shift + minus
sign (-)

Non-breaking dash (is not used for hyphenation)

Control + multiplication
sign * (only on number
pad)

Run macro field

Control + Space

Non-breaking spaces. Non-breaking spaces are not used for
hyphenation and are not expanded if the text is justified.

Shift + Enter

Line break without paragraph change

Control + Enter

Manual page break

Control + Shift + Enter

Column break in multicolumnar texts

Alt + Enter

Inserting a new paragraph without numbering

Alt + Enter

Inserting a new paragraph directly before or after a section or a table.

Arrow Left

Move cursor to left

Shift + Arrow Left

Move cursor with selection to the left

Control + Arrow Left

Go to beginning of word

Control + Shift + Arrow
Left

Selecting to the left word by word

Arrow Right

Move cursor to right

Shift + Arrow Right

Move cursor with selection to the right

Control + Arrow Right

Go to end of word

Control + Shift + Arrow
Right

Selecting to the right word by word

Arrow Up

Move up one line

Shift + Arrow Up

Selecting lines in an upwards direction

Arrow Down

Move cursor down one line

Shift + Arrow Down

Selecting lines in a downward direction

Home

Go to beginning of line

Shift + Home

Go and select to the beginning of a line

End

Go to end of line

Shift + End

Go and select to end of line

Control + Home

Go to start of document

Control + Shift + Home

Go and select text to start of document
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Shortcut Keys

Effect

Control + End

Go to end of document

Control + Shift + End

Go and select text to end of document

Control + PageUp

Switch cursor between text and header

Control + PageDown

Switch cursor between text and footer

Insert

Insert mode on/off

PageUp

Screen page up

Shift + PageUp

Move up screen page with selection

PageDown

Move down screen page

Shift + PageDown

Move down screen page with selection

Control + Del

Delete text to end of word

Control + Backspace

Delete text to beginning of word

Control + Shift + Del

Delete text to end of sentence

Control + Shift +
Backspace

Delete text to beginning of sentence

Control + Tab

Next suggestion with Automatic Word Completion

Control + Shift + Tab

Use previous suggestion with Automatic Word Completion

Alt + W

Spellchecker dialog: Call back the original unknown word into the
text box

Control + double-click or
Control + Shift + F10

Use this combination to quickly dock or undock the Navigator, Stylist
or other windows.

Shortcut Keys for Paragraphs and Heading Levels
Shortcut Keys

Effect

Control + Alt + Up
Arrow

Move the active paragraph or selected paragraphs up one paragraph.

Control + Alt + Down
Arrow

Move the active paragraph or selected paragraphs down one
paragraph.

Tab

The heading in format "Heading X" (X = 1-9) is moved down one
level in the outline.

Shift + Tab

The heading in format "Heading X" (X = 2-10) is moved up one level
in the outline.

Control + Tab

At the start of a heading: Inserts a tab stop. Depending on the Window
Manager in use, Alt + Tab may be used instead.

To change the heading level with the keyboard, first position the cursor in front of the
heading.
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Shortcut Keys for Tables in OpenOffice.org Writer
Shortcut Keys

Effect

Control + A

If the active cell is empty: selects the whole table. Otherwise: selects
the contents of the active cell. Pressing again selects the entire table.

Control + Home

If the active cell is empty: goes to the beginning of the table.
Otherwise: first press goes to beginning of the active cell, second
press goes to beginning of the current table, third press goes to
beginning of document.

Control + End

If the active cell is empty: goes to the end of the table. Otherwise: first
press goes to the end of the active cell, second press goes to the end of
the current table, third press goes to the end of the document.

Control + Tab

Inserts a tab stop (only in tables). Depending on the Window Manager
in use, Alt + Tab may be used instead.

Control + Shift + Arrow
Up

Jump to start of table

Control + Shift + Arrow
Down

Jump to end of table

Alt + Arrow Keys

Increases/decreases the size of the column/row on the right/bottom
cell edge

Alt + Shift + Arrow Keys

Increase/decrease the size of the column/row on the left/top cell edge

Alt + Control + Arrow
Keys

Like Alt, but only the active cell is modified

Control + Alt + Shift +
Arrow Keys

Like Alt, but only the active cell is modified

Alt + Insert

3 seconds in Insert mode, Arrow Key inserts row/column, Control +
Arrow Key inserts cell

Alt + Del

3 seconds in Delete mode, Arrow key deletes row/column, Control +
Arrow key merges cell with neighboring cell

Control + Shift + T

Removes cell protection from all selected tables. If no table is
selected, then cell protection is removed from all of the tables in the
document.

Shift + Control + Del

If nothing is selected, the contents of the next cell are deleted. If cells
are selected, the whole line of the selection will be deleted. If all rows
are selected completely or partially, the entire table is deleted.

Alt + Enter

Inserting a new paragraph directly before or after a section or a table.
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Shortcut Keys for Moving and Resizing Frames,
Graphics and Objects
Shortcut Keys

Effect

Esc

Cursor is inside a text frame and no text is selected: Escape selects the
text frame.
Text frame is selected: Escape clears the cursor from the text frame.

F2 or Enter or any key
that produces a character
on screen

If a text frame is selected: positions the cursor to the end of the text in
the text frame. If you press any key that produces a character on
screen, and the document is in edit mode, the character is appended to
the text.

Alt + Arrow Keys

Move object.

Alt + Control + Arrow
Keys

Resizes by moving lower right corner.

Alt + Control + Shift +
Arrow Keys

Resizes by moving top left corner.

Control + Tab

Selects the anchor of an object (in Edit Points mode).
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Appendix C Calc shortcut keys
Navigating in Spreadsheets
Shortcut Keys

Effect

Control + Home

Moves the cursor to the first cell in the sheet (A1).

Control + End

Moves the cursor to the last cell on the sheet that contains data.

Home

Moves the cursor to the first cell of the current row.

End

Moves the cursor to the last cell of the current row.

Control + Left Arrow

Moves the cursor to the left edge of the current data range. If the
column to the left of the cell that contains the cursor is empty, the
cursor moves to the next column to the left that contains data.

Control + Right Arrow

Moves the cursor to the right edge of the current data range. If the
column to the right of the cell that contains the cursor is empty, the
cursor moves to the next column to the right that contains data.

Control + Up Arrow

Moves the cursor to the top edge of the current data range. If the row
above the cell that contains the cursor is empty, the cursor moves up
to the next row that contains data.

Control + Down Arrow

Moves the cursor to the bottom edge of the current data range. If the
row below the cell that contains the cursor is empty, the cursor moves
down to the next row that contains data.

Control + Shift + Arrow

Selects all cells containing data from the current cell to the end of the
continuous range of data cells, in the direction of the arrow pressed. If
used to select rows and columns together, a rectangular cell range is
selected.

Control + Page Up

Moves one sheet to the left. In the page preview: Moves to the
previous print page

Control + Page Down

Moves one sheet to the right. In the page preview: Moves to the next
print page.

Alt + Page Up

Moves one screen to the left.

Alt + Page Down

Moves one screen page to the right.

Control + * where (*) is
the multiplication sign on
the numeric key pa

Selects the data range that contains the cursor. A range is a contiguous
cell range that contains data and is bounded by empty row and
columns.

Control + /where (/) is
the division sign on the
numeric key pad

Selects the matrix formula range that contains the cursor.

Enter - in a selected
range

Moves the cursor down one cell in a selected range. To specify the
direction that the cursor moves, choose Tools > Options > Spreadsheet
> General.
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Shortcut Keys

Effect

Control + F1

Displays the note that is attached to the current cell

F2

Switches to Edit mode and places the cursor at the end of the contents
of the current cell. Press again to exit Edit mode.
If the cursor is in an input box in a dialog that has a Minimize button,
the dialog is hidden and the input box remains visible. Press F2 again
to show the whole dialog.

Control + F2

Opens the AutoPilot for Functions.

Shift + Control + F2

Moves the cursor to the Input line where you can enter a formula for
the current cell.

Control + F3

Opens the Define Names dialog.

F4

Shows or Hides the Database explorer.

Shift + F4

Rearranges the relative or absolute references (for example, A1, $A$1,
$A1, A$1) in the input field.

F5

Shows or hides the Navigator.

Shift + F5

Traces dependents.

Shift + Control + F5

Moves the cursor from the Input line to the Sheet area box.

F7

Checks spelling in the current sheet.

Control + F7

Opens the Thesaurus if the current cell contains text.

Control + F5

Traces precedents.

F8

Turns additional selection mode on or off. In this mode, you can use
the arrow keys to extend the selection. You can also click in another
cell to extend the selection.

Control + F8

Highlights cells containing values.

F9

Recalculates all of the formulas in the sheet.

Control + F9

Updates the selected chart.

F11

Opens the Stylist where you can apply a formatting style to the
contents of the cell or to the current sheet.

Shift + F11

Creates a document template.

Shift + Control + F11

Updates the templates.

F12

Groups the selected data range.

Control + F12

Ungroups the selected data range.

Alt + Down Arrow

Increases the height of current row.

Alt + Up Arrow

Decreases the height of current row.

Alt + Right Arrow

Increases the width of the current column.

Alt + Left Arrow

Decreases the width of the current column.

Alt + Shift + Arrow Key

Optimizes the column width or row height based on the current cell.
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Formatting Cells Using Shortcut Keys
Shortcut Keys

Effect

Control + Shift + 1 (not
on the number pad)

Two decimal places, thousands separator

Control + Shift + 2 (not
on the number pad)

Standard exponential format

Control + Shift + 3 (not
on the number pad)

Standard date format

Control + Shift + 4 (not
on the number pad)

Standard currency format

Control + Shift + 5 (not
on the number pad)

Standard percentage format (two decimal places)

Control + Shift + 6 (not
on the number pad)

Standard format

Using the DataPilot
Shortcut Keys

Effect

Tab

Changes the focus by moving forwards through the areas and buttons
of the dialog.

Shift + Tab

Changes the focus by moving backwards through the areas and
buttons of the dialog.

up arrow

Moves the focus up one item in the current dialog area.

down arrow

Moves the focus down one item in the current dialog area.

left arrow

Moves the focus one item to the left in the current dialog area.

right arrow

Moves the focus one item to the right in the current dialog area.

Home

Selects the first item in the current dialog area.

End

Selects the last item in the current dialog area.

Alt and the underlined
character in the word
"Row"

Copies or moves the current field into the "Row" area.

Alt and the underlined
character in the word
"Column"

Copies or moves the current field into the "Column" area.

Alt and the underlined
character in the word
"Data"

Copies or moves the current field into the "Data" area.

Control + Up Arrow

Moves the current field up one place.
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Shortcut Keys

Effect

Control + Down Arrow

Moves the current field down one place.

Control + Left Arrow

Moves the current field one place to the left.

Control + Right Arrow

Moves the current field one place to the right.

Control + Home

Moves the current field to the first place.

Control + End

Moves the current field to the last place.

Alt + O

Displays the options for the current field.

Delete

Removes the current field from the area.
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Appendix D Impress shortcut keys
Function Keys for OpenOffice.org Impress
Shortcut Keys

Effect

F2

Edit text

F3

Edit group

Control + F3

Exit group

Shift + F3

Duplicate

F4

Position and Size

F5

Navigator

F7

Spellcheck

Control + F7

Thesaurus

F8

Edit Points

Control + Shift + F8

Fit text to frame

F9 (or Control + F2)

Start Slide Show

F11

Stylist

F12

Outline View

Control + F12

Drawing View

Shortcut Keys in Slide Shows
Shortcut Keys

Effect

F9 (or Control + F2)

Start Slide Show

Esc or Backspace or (-)
Minus key on the
numerical keypad

End presentation

Spacebar

Next animated object or next slide

Enter or Arrow Down or
N

Go to next slide

[number] – Enter

Type a number of a slide and press Enter to go to the slide.

Arrow Left or Arrow Up
or P

Go to the previous slide

Arrow Right

Go to the next slide

Home (Pos 1)

Jump to first slide in the slide show
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Shortcut Keys

Effect

End

Jump to the last slide in the slide show

Control + Page Up

Go to the previous slide

Control + Page Down

Go to the next slide

F5

Open the Navigator

B

Toggle screen to black

W

Toggle screen to white

Shortcut Keys in the Drawing View
Shortcut Keys

Effect

Plus( + ) Key

Zoom in

Minus(-) Key

Zoom out

Times(×) Key (number
pad)

Fit page in window

Divide(÷) Key (number
pad)

Zoom in on current selection

Shift + Control + G

Group selected objects

Shift + Control + Alt + A

Ungroup selected group

Control + click

Enter a group, so that you can edit the individual objects of the group.
Click outside the group to return to the normal view.

Shift + Control + K

Combine selected objects.

Shift + Control + K

Split selected object. This combination only works on an object that
was created by combining two or more objects.

Shift + Control + Plus
key

Bring to Front

Shift + Control + Plus
key

Bring Forward

Shift + Control + Minus
key

Send Backward

Shift + Control + Minus
key

Send to Back
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Shortcut Keys for OpenOffice.org Impress
Shortcut Keys

Effect

Arrow key

Moves the selected object or the page view in the direction of the
arrow.

Crtl + Arrow Key

Move around in the page view.

Shift + drag

Constrains the movement of the selected object horizontally or
vertically.

Control + drag (with
Copy when moving
option active)

Hold down Control and drag an object to create a copy of the object.

Alt Key

Hold down Alt to draw or resize objects by dragging from the center
of the object outward.

Alt key + click

Select the object behind the currently selected object.

Alt + Shift + click

Select the object in front of the currently selected object.

Shift + click

Select adjacent items or a text passage. Click at the start of a selection,
move to the end of the selection, and then hold down Shift while you
click.

Shift + drag (when
resizing)

Hold down Shift while dragging to resize an object to maintain the
proportions of the object.

Tab key

Select objects in the order in which they were created.

Shift + Tab

Select objects in the reverse order in which they were created.

Escape

Exit current mode.

Enter

Activate a placeholder object in a new presentation (only if the frame
is selected).

Control + Enter

Moves to the next text object on the slide. If there are no text objects
on the slide, or if you reached the last text object, a new slide is
inserted after the current slide. The new slide uses the same layout as
the current slide.

Navigating with the Keyboard in Slide View
Shortcut Keys

Effect

Escape

Moves the focus to the first slide.

Arrow key

Moves the focus to the next slide.

Spacebar

Makes the slide with the focus the current slide.
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Appendix E Draw Shortcut keys
General Draw shortcut keys
Shortcut Keys

Effect

F2

Add or edit text

F3

Opens group to edit individual objects

Control + F3

Close group editor

Shift + F3

Opens the Duplicate dialog

F4

Opens the Position and Size dialog

F5

Opens the Navigator

F7

Checks spelling

Control + F7

Opens the Thesaurus

F8

Edit points on/off

Control + Shift + F8

Fits to frame

F11

Opens Stylist

Plus( + ) Key

Zooms in

Minus(-) Key

Zooms out

Multiple(×) Key (number
pad)

Zooms to fit entire page in screen

Divide (÷) Key (number
pad)

Zooms in on the current selection

Control + Shift + G

Groups selected objects

Shift + Control + Alt + A

Ungroups selected group

Control + Shift + K

Combines selected objects

Control + Alt + Shift + K

Uncombines selected object

Control + Shift + +

Bring to front

Control + +

Bring forward

Control + -

Send backward

Control + Shift + -

Send to back

Arrow Key

Moves the selected object in the direction of the arrow key.

Control + Arrow Key

Moves the page view in the direction of the arrow key.

Shift + drag with mouse

The movement of the selected object is constrained by multiples of 45
degrees.
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Shortcut Keys

Effect

Control + Click while
dragging an object.

Note: you must first enable the Copy when moving option in Tools Options - Drawing - General to use this shortcut key.
Creates a copy of the dragged object when mouse button is released.

Control + Enter with
keyboard focus (F6) on
an object in Main
Toolbar

Inserts a drawing object of default size into the center of the current
view.

Shift + F10

Opens the context menu for the selected object.

F2

Enters text mode.

Enter

Enters text mode if a text object is selected.

Control + Enter

Enters text mode if a text object is selected. If there are no text objects
or if you have cycled through all of the text objects on the page, a new
page is inserted.

Alt

Press the Alt key and drag with the mouse to draw or resize an object
from the center of the object outward.

Alt + click on an object

Selects the object behind the currently selected object.

Alt + Shift + click an
object

Selects the object in front of the currently selected object.

Shift key while selecting
an object

Adds or removes object to or from the selection.

Shift + drag while
creating or resizing an
object

Constrains the dimensions of the object to multiples of 45 degrees.

Tab

Cycles through the objects on the page in the order in which they were
created.

Shift + Tab

Cycles through the objects on the page in the reverse-order in which
they were created.

Esc

Exits current mode.

Shortcut Keys for 3D Effects (Illumination tab)
Shortcut Keys

Effect

Page Up

Changes the light source in the preview window.

Page Down

Changes the light source in the preview window.

Arrow keys

Moves the current light source in the direction of the arrow.

Spacebar

Enables the current light source and turns it on or off.
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Shortcut Keys
Control + Enter

Effect
Moves to the next text object on the slide.
If there are no text objects on the slide, or if you reached the last text
object, a new slide is inserted after the current slide. The new slide
uses the same layout as the current slide.

Navigating with the Keyboard in Slide View
Shortcut Keys

Effect

Escape

Moves the focus to the first slide.

Arrow key

Moves the focus to the next slide.

Spacebar

Makes the slide with the focus the current slide.
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Appendix F Chart Shortcut keys
Shortcut Keys

Results

Tab

Select next object.

Shift + Tab

Select previous object.

Home

Select first object.

End

Select last object.

Esc

Cancel selection

up/down/left/right arrow

Move the object in the direction of the arrow.

up/down/left/right arrow
in pie charts

Moves the selected pie segment in the direction of the arrow.

F2 in titles

Enter text input mode.

F3

Open group so that you can edit the individual components (in legend
and data series).

Control + F3

Exit group (in legend and data series).

+ /-

Reduce or enlarge the chart

+ /- in pie charts

Moves the selected pie segment off or into the pie chart.
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Appendix G PowerPoint custom animations –
Impress object effects
These are how the custom animations / object effects are imported into Impress and
exported to PowerPoint.

PowerPoint

Impress

Appear

Appear

Blinds

Fade Horizontally

Box

Fade To Center

Checkerboard

Checkerboard

Diamond

Appear

Crawl

Fly In From bottom

Dissolve

Dissolve

Flash once

Appear

Peek

Short Fly In from
Bottom

Random Bars

Horizontal lines

Spiral

Spiral Outward
Clockwise

Split

Close Vertical

Stretch

Stretch Vertical

Strips

Fade From Top Right

Swivel

Rotate Horizontally

Wipe

Cross-Fade From Top

Zoom

Fade From Center

Random effects

Vertical Lines
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Appendix H PowerPoint – Impress slide
transitions
These are how the slide transitions are imported into Impress and exported to
PowerPoint.

PowerPoint

Impress

PowerPoint

Impress

Blinds Horizontal

Fade Horizontally

Horizontal Out

Open Vertically

Blind Verrtical

Fade Verticaly

Split Vertical In

Close Horizontally

Box In

Fade To Center

Split Vertical Out

Open Horizontally

Box Out

Fade From Center

Strips Left Down

Fade From Top Right

Checkerboard Across

Horizontal
Checkerboard

Strips Left Up

Fade From Bottom
Right

Checkerboard Down

Vertical Checkerboard

Strips Right Down

Fade From Top Left

Cover Down

Fly In From Top

Strips Right Up

Fade From Bottom Left

Cover Left

Fly In From Right

Uncover Down

Uncover Downwards

Cover Right

Fly In From Left

Uncover Left

Uncover To Left

Cover Up

Fly In From Bottom

Uncover Right

Uncover To Right

Cover Left Down

Fly In From Upper
Right

Uncover Up

Uncover Upwards

Uncover Left Down

Uncover To Lower Left

Cover Right Down

Fly In From Top Left

Uncover Left Up

Uncover To Upper Left

Cover Left Down

Fly In From Upper
Right

Uncover Right Down

Uncover To Lower
Right

Cover Right Up

Fly In From Lower Left

Uncover Right Up

Cut

No effect

Uncover To Upper
Right

Cut through Black

No effect

Wipe Down

Cross-Fade From Top

Dissolve

Dissolve

Wipe Left

Cross-Fade From Right

Fade Through Black

No effect

Wipe Right

Cross-Fade From Left

Random Bars
Horizontally

Horizontal Lines

Wipe Up

Cross Fade From
Bottom

Random Bars
Vertically

Vertical Lines

Random Transition

Automatic (random)

Horizontal In

Close Vertically
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Appendix I Math formula – symbols and
commands
This appendix is copied from a document by Fred Saalbach, available from:
http://qa.openoffice.org/issues/show_bug.cgi?id=15405.

Unary / Binary Operators
Operation

Command

Display

+sign

+1

1

-sign

-1

−1

+/- sign

+-1

±1

-/+ sign

neg 1

∓1

Boolean not

neg a

¬a

Addition +

a+b

ab

Multiplication dot

a cdot b

a⋅b

Multiplication (X)

a times b

a×b

Multiplication (*)

a*b

a∗b

Boolean and

a and b

a∧b

Subtraction (-)

a-b

a−b

Division (fraction)

a over b

a
b

Division (operand)

a div b

a÷b

Division (slash)

a/b

a/b

Boolean or

a or b

a∨b

Concatenate

a circ b

a°b

Table 15Commands, unary & binary.Relations
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Relational Operators
Operation

Command

Display

Is equal

a=b

a=b

Is not equal

a <> b

a≠2

Approximately

a approx 2

a≈2

Divides

a divides b

a∣b

Does not divide

a ndivides b

a∤ b

Less than

a<2

a2

Greater than

a>2

a2

Similar to or equal

a simeq b

a≃b

Parallel

a parallel b

a∥b

Orthogonal to

a ortho b

a⊥b

Less than or equal to

a leslant b

ab

Greater than or equal to

a geslant b

ab

Similar to

a sim b

a~b

Congruent

a equiv b

a≡b

Less than or equal to

a <= b

a≤b

Greater than or equal to

a >= b

a≥b

Proportional

a prop b

a∝b

Toward

a toward b

ab

Arrow left

a dlarrow b

a⇐ b

Double arrow left and
right

a dlrarrow b

a⇔b

Arrow right

a drarrow b

a⇒b

Table 16Commands, relations.
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Set Operations
Operation

Command

Display

Is in

a in b

a∈b

Is not in

a notin b

a∉b

Owens

a owns b

a∋b

Empty set

emptyset

∅

Intersection

a intersection b

a∩b

Union

a union b

a∪b

Difference

a setminus b

a∖ b

Quotient

a slash b

a/b

Aleph

aleph

ℵ

Subset

a subset b

a⊂b

Subset or equal to

a subseteq b

a⊆b

Superset

a supset b

a⊃b

Superset or equal to

a supseteq b

a⊇b

Not subset

a nsubset b

a⊄b

Not subset or equal

a nsubseteq b

a⊈b

Not superset

a nsupset b

a⊅b

Not Superset or equal

a nsupseteq b

a⊉b

Natural Numbers Set

setN

ℕ

Set of Integers

setZ

ℤ

Set of rational numbers

setQ

ℚ

Set of real numbers

setR

ℝ

Set of complex numbers

setC

ℂ

Table 17Commands, set operators.
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Functions
Operation

Command

Exponential

func e^{a}

e

Natural logarithm

ln(a)

ln  a

Exponential function

exp(a)

exp  a

Logarithm

log(a)

log  a

Power

a^{b}

a

Sine

sin(a)

sin  a

Cosine

cos(a)

cos  a

Tangent

tan(a)

tan  a

Cotangent

cot(a)

cot  a

Square root

sqrt{a}

a

Arcsine

arcsin(a)

arcsin  a

Arc cosine

arccos(a)

arccos  a

Arctangent

arctan(a)

arctan  a

Arc cotangent

arccot(a)

arccot  a

n root

nroot{a}{b}

a b

Hyperbolic sine

sinh(a)

sinh  a 

Hyperbolic cosine

cosh(a)

cosh  a

Hyperbolic tangent

tanh(a)

tanh  a 

Hyperbolic cotangent

coth(a)

coth  a

Absolute value

abs{a}

∣a∣

Arc hyperbolic sine

arsinh(a)

arsinh  a

Arc hyperbolic cosine

arccosh(a)

arcosh  a 

Arc hyperbolic tangent

arctanh(a)

artanh  a

Arc hyperbolic cotangent

arccoth(a)

arcoth  a 

factorial

fact(a)

a!

th

Display
a

b

Table 18Commands, function.
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Operators
All operators can be used with the limit functions (“from” and “to”)
Operation

Command

Limit

Lim(a)

Sum

sum(a)

Product

prod(a)

Coproduct

coprod(a)

Limits from and to
(shown with intigral)

int from {r_0} to {r_t} a

Display
lim a

∑a
∏a
∐a
rt

∫a
r0

Intigral

int{a}

Double intigral

iint{a}

Tripple Intigral

iiint{a}

Lower limit shown with
summation symbol

sum from{3}b

Curved intigeral

lint a

Double curved intigeral

llint a

Tripple curved intigeral

lllint a

Upper limit shown with
product symbol

prod to{3} r

∫a
∬a
∭a
∑b
3

∮a
∯a
∰a
3

∏r

Table 19Commands, operators.
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Attributes
Operation

Command

Display

Acute accent

acute a

a

Grave accent

grave a

a

Reverse circumflex

check a

a

Breve

breve a

a

Circle

circle a

å

Vector arrow

vec a

a

Tilde

tilde a

Circumflex

hat a

a
a

Line above

bar a

Dot

dot a

Wide vector arrow

widevec abc

Wide tilde

widetilde abc

Wide circumflex

widehat abc

a
bc

abc

Double dot

ddot

ä

Line over

overline abc

abc

Line under

Underline abc

abc

Line through

overstrike acb

acb

Ripple dot

dddot a

a

Transparent (useful to get
a placeholder of a given
size)

phantom a

Bold font

bold a

a

Italic font5

ital a

a

Resize font

size 16 qv

qv

a
ȧ

abc

Table 20Commands, attributes.

5 Unquoted text that isn't a command is considered to be a variable. Variables are, by default, italicized.
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Attributes Continued
Operation

Command

Following item in sans
serif font6

font sans qv

qv

Following item in serif
font

font serif qv

qv

Following item in fixed
font

font fixed qv

Display

qv

Make color of following
text cyan

color cyan qv

qv

Make color of following
text yellow

color yellow qv

qv

Make color of following
text green

color white qv

qv

Make color of following
text white

color green qv

qv

Make color of following
text blue

color blue qv

qv

Make color of following
text red

color red qv

qv

Make color green returns
to default color black

color green X qv

Xqv

Brace items to change
color of more than one
item

color green {X qv}

Xqv

Table 21Commands, attributes – continued.

Others
Operation

Command

Display

Infinity

infinity

∞

Partial

partial

∂

Nabla

nabla

∇

There exists

exists

∃

6 There are three custom fonts, sans serif (without kicks), serifs (with kicks), and fixed (non
proportional). To change the actual fonts used for custom fonts and the fonts used for variables
(unquoted text), numbers and functions, use: Format > Fonts.
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Operation

Command

Display

For all

forall

∀

H bar

hbar

ℏa

Lambda bar

lambdabar

ƛ

Real part

re

ℜ

Imaginary part

im

ℑ

Weierstrss p

wp

℘

Left arrow

leftarrow



Right arrow

rightarrow



Up arrow

uparrow



Down arrow

downarrow



Dots at bottom

dotslow



Dots at middle

dotsaxis

⋯

Dots vertical

dotsvert

⋮

Dots diagonal upward

dotsup

⋰

Dots diagonal downward

dotsdown

⋱

Table 22Commands, others.
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Brackets
Operation

Command

Display

Round Brackets

(a)

 a

Square Brackets

[b]

[ b]

Double Square Brackets

ldbracket c rdbracket

〚c〛

Single line

lline a rline

∣a∣

Double line

ldline a rdline

∥a∥

Braces

lbrace w rbrace

{w}

Angle Brackets

langle d rangle

〈d 〉

Operator Brackets

langle a mline b rangle

〈 a∣b〉

Group brackets (used for
program control)

{a}

a

Round brackets scalable
(To make brackets
scalable add the word
“left before a left bracket
and “right” before a right
bracket

left ( stack{a # b # z} right )

Square brackets scalable

left [ b right ]

Double square brackets
scalable

left ldbracket c right
rdbracket

Line scalable

left lline a right rline

Double line scalable

left ldline d right rdline

Brace scalable

left lbrace e right rbrace

Angle bracket scalable

left langle f right rangle

Operator brackets
scalable

left langle g mline h right
rangle

Over brace scalable

{The brace is above}
overbrace a

Under brace scaleable

{the brace is below}
underbrace {f}


a
b
z

[ b]
〚c〛
∣a∣
∥d∥
{e }
〈f 〉
〈 g∣h 〉
a

The brace is above

the brace is below

f

Table 23Commands, braces.
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Formats
Operation

Command

Left Superscript

a lsup{b}

Display
b

a

b

Center Superscript
sum(a)a csup{b}

a

Right Superscript

a^{b}

a

Left subscript

a lsub{b}

Center subscript

a csub{b}

b

b

a

a
b

Right subscript

a_{b}

ab

Align character to left

(alignl(a))

 a

Align character to center

(alignc(a))

 a

Align character to right

(alignr(a))

 a

Vertical stack of 2

binom{a}{b}

a
b

Vertical stack, more than
2

stack{a # b # z}

a
b
z

Matrix stack

matrix{a # b ## c # d}

a b
c d

Common mathematical
arrangement

matrix{a # "="b ## {} #
"="c}

a =b
=c

New Line

asldkfjo newline sadkfj

asldkfjo
sadkfj

Small gap (apostrophe)

stuff`stuff

stuff stuff

Large gap (tilde)

stuff~stuff

stuff stuff

Table 24Commands, formats.
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Characters - Greek
%ALPHA

A

B

H

%ETA

%MU

%DELTA

%BETA

M

%KAPPA

%GAMMA


%NU

%IOTA

N



K

%RHO

%UPSILON

%XI 

%ZETA

P

%EPSILON

E

%LAMBDA



%OMICRON

%PHI 

%SIGMA

%THETA

O

%PSI 





Z



%chi 

%delta 

%epsilon

%eta 

%gamma

%iota 

%kappa 

%lambda

%mu 

%nu 

%omega

%omicron

%phi 

%pi 

%rho 

%sigma 

%tau 

%theta 

%upsilon

%varepsilon

%varphi

%varpi 

%varrho

%alpha



I

%OMEGA

%PI 





X

%CHI


%varsigma



%beta











%vartheta






ϱ

∧

%xi 

%zeta 

%element

%identical

%infinite

%perthousand

%
strictlygreatert
han ≫

Table 25Characters, Greek.

Characters - Special
%and
%angle

∢

∈

%noelement

∉

%
strictlylessthan

≪

%notequal

≠

%or

∨

≡



∞

%tendto



Table 26Characters, special.
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